Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742730

Re: [PATCH net-next v2 0/7] net: dsa: change dsa_ptr for a dsa_port

From David Miller <davem@davemloft.net>
Newsgroups linux.kernel
Subject Re: [PATCH net-next v2 0/7] net: dsa: change dsa_ptr for a dsa_port
Date 2017-10-01 05:20 +0200
Message-ID <uvCXn-4YV-1@gated-at.bofh.it> (permalink)
References <uvb17-3ao-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Date: Fri, 29 Sep 2017 17:19:14 -0400

> With DSA, a master net_device is physically wired to a dedicated CPU
> switch port. For interaction with the DSA layer, the struct net_device
> contains a dsa_ptr, which currently points to a dsa_switch_tree object.
> 
> This is only valid for a switch fabric with a single CPU port. In order
> to support switch fabrics with multiple CPU ports, we first need to
> change the type of dsa_ptr to what it really is: a dsa_port object.
> 
> This is what this patchset does. The first patches adds a
> dsa_master_get_slave helper and cleans up portions of DSA core to make
> the next patches more readable. These next patches prepare the xmit and
> receive hot paths and finally change dsa_ptr.
> 
> Changes in v2:
>   - introduce dsa_master_get_slave helper to simplify patch 6
>   - keep hot path data at beginning of dsa_port for cacheline 1

Series applied, thank you.

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH net-next v2 0/7] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 23:30 +0200
  [PATCH net-next v2 6/7] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 23:30 +0200
  Re: [PATCH net-next v2 0/7] net: dsa: change dsa_ptr for a dsa_port David Miller <davem@davemloft.net> - 2017-10-01 05:20 +0200

csiph-web