Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1608422
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth |
| Date | 2017-03-24 15:10 +0100 |
| Message-ID | <toy4G-2Fu-31@gated-at.bofh.it> (permalink) |
| References | <toh3P-72e-5@gated-at.bofh.it> <toh3P-72e-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Mar 24, 2017 at 04:52:58AM +0100, luca abeni wrote:
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 20c62e7..efa88eb 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -6716,6 +6716,12 @@ static void sched_dl_do_global(void)
> raw_spin_unlock_irqrestore(&dl_b->lock, flags);
>
> rcu_read_unlock_sched();
> + if (dl_b->bw == -1)
> + cpu_rq(cpu)->dl.deadline_bw_inv = 1 << 8;
> + else
> + cpu_rq(cpu)->dl.deadline_bw_inv =
> + to_ratio(global_rt_runtime(),
> + global_rt_period()) >> 12;
Coding style requires braces here (on both legs of the condition)..
Also, I find deadline_bw_inv an awkward name; would something like
bw_ratio or so be more accurate?
> + if (global_rt_runtime() == RUNTIME_INF)
> + dl_rq->deadline_bw_inv = 1 << 8;
> + else
> + dl_rq->deadline_bw_inv =
> + to_ratio(global_rt_runtime(), global_rt_period()) >> 12;
That's almost the same code; do we want a helper function?
>
> u64 grub_reclaim(u64 delta, struct rq *rq)
> {
> + return (delta * rq->dl.running_bw * rq->dl.deadline_bw_inv) >> 20 >> 8;
> }
At which point we might want a note about how this doesn't overflow I
suppose.
Also:
delta *= rq->dl.running_bw;
delta *= rq->dl.bw_ratio;
delta >>= 20 + 8;
return delta;
Might be more readable ?
Alternatively:
delta = (delta * rq->dl.running_bw) >> 8;
delta = (delta * rq->dl.bw_ratio) >> 20;
return delta;
But I doubt we care about those extra 8 bit of space; delta should not
be over 36 bits (~64 seconds) anyway I suppose.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth luca abeni <luca.abeni@santannapisa.it> - 2017-03-23 21:00 +0100
Re: [RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth Peter Zijlstra <peterz@infradead.org> - 2017-03-24 15:10 +0100
Re: [RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth luca abeni <luca.abeni@santannapisa.it> - 2017-03-24 23:00 +0100
Re: [RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth Steven Rostedt <rostedt@goodmis.org> - 2017-03-25 03:40 +0100
Re: [RFC v5 5/9] sched/deadline: do not reclaim the whole CPU bandwidth Peter Zijlstra <peterz@infradead.org> - 2017-03-27 10:40 +0200
csiph-web