Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1603067

[PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced

From "Huang, Ying" <ying.huang@intel.com>
Newsgroups linux.kernel
Subject [PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced
Date 2017-03-17 07:50 +0100
Message-ID <tlTS1-20n-7@gated-at.bofh.it> (permalink)
References <tlTS1-20n-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Huang Ying <ying.huang@intel.com>

This is just a cleanup patch, no functionality change.  In
cluster_list_add_tail(), spin_lock_nested() is used to lock the
cluster, while unlock_cluster() is used to unlock the cluster.  To
improve the code readability.  Use spin_unlock() directly to unlock
the cluster.

Signed-off-by: "Huang, Ying" <ying.huang@intel.com>
Acked-by: Tim Chen <tim.c.chen@intel.com>
---
 mm/swapfile.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/mm/swapfile.c b/mm/swapfile.c
index 6b6bb1bb6209..42fd620dcf4c 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -335,7 +335,7 @@ static void cluster_list_add_tail(struct swap_cluster_list *list,
 		ci_tail = ci + tail;
 		spin_lock_nested(&ci_tail->lock, SINGLE_DEPTH_NESTING);
 		cluster_set_next(ci_tail, idx);
-		unlock_cluster(ci_tail);
+		spin_unlock(&ci_tail->lock);
 		cluster_set_next_flag(&list->tail, idx, 0);
 	}
 }
-- 
2.11.0

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced "Huang, Ying" <ying.huang@intel.com> - 2017-03-17 07:50 +0100

csiph-web