Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1603067 > unrolled thread

[PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced

Started by"Huang, Ying" <ying.huang@intel.com>
First post2017-03-17 07:50 +0100
Last post2017-03-17 07:50 +0100
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced "Huang, Ying" <ying.huang@intel.com> - 2017-03-17 07:50 +0100

#1603067 — [PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced

From"Huang, Ying" <ying.huang@intel.com>
Date2017-03-17 07:50 +0100
Subject[PATCH 2/5] mm, swap: Improve readability via make spin_lock/unlock balanced
Message-ID<tlTS1-20n-7@gated-at.bofh.it>
From: Huang Ying <ying.huang@intel.com>

This is just a cleanup patch, no functionality change.  In
cluster_list_add_tail(), spin_lock_nested() is used to lock the
cluster, while unlock_cluster() is used to unlock the cluster.  To
improve the code readability.  Use spin_unlock() directly to unlock
the cluster.

Signed-off-by: "Huang, Ying" <ying.huang@intel.com>
Acked-by: Tim Chen <tim.c.chen@intel.com>
---
 mm/swapfile.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/mm/swapfile.c b/mm/swapfile.c
index 6b6bb1bb6209..42fd620dcf4c 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -335,7 +335,7 @@ static void cluster_list_add_tail(struct swap_cluster_list *list,
 		ci_tail = ci + tail;
 		spin_lock_nested(&ci_tail->lock, SINGLE_DEPTH_NESTING);
 		cluster_set_next(ci_tail, idx);
-		unlock_cluster(ci_tail);
+		spin_unlock(&ci_tail->lock);
 		cluster_set_next_flag(&list->tail, idx, 0);
 	}
 }
-- 
2.11.0

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web