Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1654421

[PATCH 19/24] partitions/ldm: switch to use uuid_t

From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject [PATCH 19/24] partitions/ldm: switch to use uuid_t
Date 2017-05-31 18:30 +0200
Message-ID <tNeFs-7az-19@gated-at.bofh.it> (permalink)
References <tNevL-77a-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


And the uuid helpers.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 block/partitions/ldm.c | 10 +++++-----
 block/partitions/ldm.h |  6 ++----
 2 files changed, 7 insertions(+), 9 deletions(-)

diff --git a/block/partitions/ldm.c b/block/partitions/ldm.c
index edcea70674c9..2a365c756648 100644
--- a/block/partitions/ldm.c
+++ b/block/partitions/ldm.c
@@ -115,7 +115,7 @@ static bool ldm_parse_privhead(const u8 *data, struct privhead *ph)
 		ldm_error("PRIVHEAD disk size doesn't match real disk size");
 		return false;
 	}
-	if (uuid_be_to_bin(data + 0x0030, (uuid_be *)ph->disk_id)) {
+	if (uuid_parse(data + 0x0030, &ph->disk_id)) {
 		ldm_error("PRIVHEAD contains an invalid GUID.");
 		return false;
 	}
@@ -234,7 +234,7 @@ static bool ldm_compare_privheads (const struct privhead *ph1,
 		(ph1->logical_disk_size  == ph2->logical_disk_size)	&&
 		(ph1->config_start       == ph2->config_start)		&&
 		(ph1->config_size        == ph2->config_size)		&&
-		!memcmp (ph1->disk_id, ph2->disk_id, GUID_SIZE));
+		uuid_equal(&ph1->disk_id, &ph2->disk_id));
 }
 
 /**
@@ -557,7 +557,7 @@ static struct vblk * ldm_get_disk_objid (const struct ldmdb *ldb)
 
 	list_for_each (item, &ldb->v_disk) {
 		struct vblk *v = list_entry (item, struct vblk, list);
-		if (!memcmp (v->vblk.disk.disk_id, ldb->ph.disk_id, GUID_SIZE))
+		if (uuid_equal(&v->vblk.disk.disk_id, &ldb->ph.disk_id))
 			return v;
 	}
 
@@ -892,7 +892,7 @@ static bool ldm_parse_dsk3 (const u8 *buffer, int buflen, struct vblk *vb)
 	disk = &vb->vblk.disk;
 	ldm_get_vstr (buffer + 0x18 + r_diskid, disk->alt_name,
 		sizeof (disk->alt_name));
-	if (uuid_be_to_bin(buffer + 0x19 + r_name, (uuid_be *)disk->disk_id))
+	if (uuid_parse(buffer + 0x19 + r_name, &disk->disk_id))
 		return false;
 
 	return true;
@@ -927,7 +927,7 @@ static bool ldm_parse_dsk4 (const u8 *buffer, int buflen, struct vblk *vb)
 		return false;
 
 	disk = &vb->vblk.disk;
-	memcpy (disk->disk_id, buffer + 0x18 + r_name, GUID_SIZE);
+	uuid_copy(&disk->disk_id, (uuid_t *)(buffer + 0x18 + r_name));
 	return true;
 }
 
diff --git a/block/partitions/ldm.h b/block/partitions/ldm.h
index 374242c0971a..f4c6055df956 100644
--- a/block/partitions/ldm.h
+++ b/block/partitions/ldm.h
@@ -112,8 +112,6 @@ struct frag {				/* VBLK Fragment handling */
 
 /* In memory LDM database structures. */
 
-#define GUID_SIZE		16
-
 struct privhead {			/* Offsets and sizes are in sectors. */
 	u16	ver_major;
 	u16	ver_minor;
@@ -121,7 +119,7 @@ struct privhead {			/* Offsets and sizes are in sectors. */
 	u64	logical_disk_size;
 	u64	config_start;
 	u64	config_size;
-	u8	disk_id[GUID_SIZE];
+	uuid_t	disk_id;
 };
 
 struct tocblock {			/* We have exactly two bitmaps. */
@@ -154,7 +152,7 @@ struct vblk_dgrp {			/* VBLK Disk Group */
 };
 
 struct vblk_disk {			/* VBLK Disk */
-	u8	disk_id[GUID_SIZE];
+	uuid_t	disk_id;
 	u8	alt_name[128];
 };
 
-- 
2.11.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

cleanup UUID types V6 Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
  [PATCH 02/24] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
  [PATCH 07/24] nfsd: namespace-prefix uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
  [PATCH 01/24] uuid,afs: move struct uuid_v1 back into afs Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
    Re: [PATCH 01/24] uuid,afs: move struct uuid_v1 back into afs David Howells <dhowells@redhat.com> - 2017-05-31 20:30 +0200
  [PATCH 06/24] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
  [PATCH 09/24] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 10/24] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 18/24] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 12/24] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 11/24] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 16/24] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 24/24] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 19/24] partitions/ldm: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 15/24] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
    Re: [PATCH 15/24] block: remove blk_part_pack_uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-31 20:20 +0200
      Re: [PATCH 15/24] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 21:40 +0200
  [PATCH 23/24] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 17/24] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 13/24] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 21/24] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 14/24] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 20/24] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
    Re: [PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-31 20:20 +0200
      Re: [PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 21:50 +0200
  [PATCH 22/24] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
  [PATCH 05/24] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200

csiph-web