Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1654434
| From | Christoph Hellwig <hch@lst.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 20/24] sysctl: switch to use uuid_t |
| Date | 2017-05-31 18:30 +0200 |
| Message-ID | <tNeFt-7az-47@gated-at.bofh.it> (permalink) |
| References | <tNevL-77a-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
kernel/sysctl_binary.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/kernel/sysctl_binary.c b/kernel/sysctl_binary.c
index ece4b177052b..939a158eab11 100644
--- a/kernel/sysctl_binary.c
+++ b/kernel/sysctl_binary.c
@@ -1119,7 +1119,7 @@ static ssize_t bin_uuid(struct file *file,
/* Only supports reads */
if (oldval && oldlen) {
char buf[UUID_STRING_LEN + 1];
- uuid_be uuid;
+ uuid_t uuid;
result = kernel_read(file, 0, buf, sizeof(buf) - 1);
if (result < 0)
@@ -1128,7 +1128,7 @@ static ssize_t bin_uuid(struct file *file,
buf[result] = '\0';
result = -EIO;
- if (uuid_be_to_bin(buf, &uuid))
+ if (uuid_parse(buf, &uuid))
goto out;
if (oldlen > 16)
--
2.11.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
cleanup UUID types V6 Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
[PATCH 02/24] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
[PATCH 07/24] nfsd: namespace-prefix uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
[PATCH 01/24] uuid,afs: move struct uuid_v1 back into afs Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
Re: [PATCH 01/24] uuid,afs: move struct uuid_v1 back into afs David Howells <dhowells@redhat.com> - 2017-05-31 20:30 +0200
[PATCH 06/24] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-31 18:20 +0200
[PATCH 09/24] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 10/24] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 18/24] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 12/24] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 11/24] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 16/24] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 24/24] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 19/24] partitions/ldm: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 15/24] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
Re: [PATCH 15/24] block: remove blk_part_pack_uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-31 20:20 +0200
Re: [PATCH 15/24] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 21:40 +0200
[PATCH 23/24] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 17/24] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 13/24] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 21/24] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 14/24] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 20/24] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
Re: [PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-31 20:20 +0200
Re: [PATCH 08/24] uuid: rename uuid_to_bin to uuid_parse Christoph Hellwig <hch@lst.de> - 2017-05-31 21:50 +0200
[PATCH 22/24] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
[PATCH 05/24] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-31 18:30 +0200
csiph-web