Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1652767

Re: [PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing unused memory on PPC32

From Balbir Singh <bsingharora@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing unused memory on PPC32
Date 2017-05-30 04:00 +0200
Message-ID <tMEBX-go-1@gated-at.bofh.it> (permalink)
References <tMuVX-1P8-11@gated-at.bofh.it> <tMuVY-1P8-37@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, 29 May 2017 17:32:00 +0200 (CEST)
Christophe Leroy <christophe.leroy@c-s.fr> wrote:

> As seen below, allthough the init sections have been freed, the
> associated memory area is still marked as executable in the
> page tables.

Good catch!

Acked-by: Balbir Singh <bsingharora@gmail.com>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/7] powerpc/mm: Fix kernel protection and implement STRICT_KERNEL_RWX on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
  [PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing  unused memory on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
    Re: [PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing  unused memory on PPC32 Balbir Singh <bsingharora@gmail.com> - 2017-05-30 04:00 +0200
  [PATCH 4/7] powerpc/mm: Implement STRICT_KERNEL_RWX on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
  [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on  PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
    Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page()  on PPC32 Balbir Singh <bsingharora@gmail.com> - 2017-05-30 03:40 +0200
    Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 Michael Ellerman <mpe@ellerman.id.au> - 2017-05-30 13:00 +0200
      Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on  PPC32 Christophe LEROY <christophe.leroy@c-s.fr> - 2017-05-30 14:50 +0200

csiph-web