Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1653192
| From | Christophe LEROY <christophe.leroy@c-s.fr> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 |
| Date | 2017-05-30 14:50 +0200 |
| Message-ID | <tMOL0-7oW-13@gated-at.bofh.it> (permalink) |
| References | <tMuVX-1P8-11@gated-at.bofh.it> <tMuVY-1P8-43@gated-at.bofh.it> <tMN2x-6he-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Le 30/05/2017 à 12:50, Michael Ellerman a écrit : > Christophe Leroy <christophe.leroy@c-s.fr> writes: > > ... > > Please tell me why. Because of patch https://patchwork.ozlabs.org/patch/766777/ which modifies patch_instruction() to use an alternative mapping. Compilation fails on PPC32 because map_kernel_page() only exists on PPC64. However we have map_page() which does the same on PPC32, hence the renaming. > > You also moved the declaration from mmu_decl.h to book3s/32/pgtable.h, > but didn't update any includes, presumably we're confident everything > gets pgtable.h somehow? Yes I did that so that lib/code_patching.c sees it. All users of map_page() already include pgtable in a way or another. Christophe
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0/7] powerpc/mm: Fix kernel protection and implement STRICT_KERNEL_RWX on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
[PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing unused memory on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
Re: [PATCH 3/7] powerpc/mm: Fix kernel RAM protection after freeing unused memory on PPC32 Balbir Singh <bsingharora@gmail.com> - 2017-05-30 04:00 +0200
[PATCH 4/7] powerpc/mm: Implement STRICT_KERNEL_RWX on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
[PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 Christophe Leroy <christophe.leroy@c-s.fr> - 2017-05-29 17:40 +0200
Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 Balbir Singh <bsingharora@gmail.com> - 2017-05-30 03:40 +0200
Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 Michael Ellerman <mpe@ellerman.id.au> - 2017-05-30 13:00 +0200
Re: [PATCH 1/7] powerpc/mm: rename map_page() to map_kernel_page() on PPC32 Christophe LEROY <christophe.leroy@c-s.fr> - 2017-05-30 14:50 +0200
csiph-web