Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.os.linux.networking > #4543
| From | Eric Pozharski <whynot@pozharski.name> |
|---|---|
| Newsgroups | comp.os.linux.networking |
| Subject | Re: non-autoritative localhost, 1..12 sacle, how bad is it? |
| Date | 2020-05-03 16:53 +0300 |
| Organization | A noiseless patient Spider |
| Message-ID | <slrnratj69.hif.whynot@orphan.zombinet> (permalink) |
| References | <slrnramf8r.2f1.whynot@orphan.zombinet> <r8ho17$8ki$1@dont-email.me> <slrnrarbmt.7cj.whynot@orphan.zombinet> <r8lj5k$ia3$1@dont-email.me> |
with <r8lj5k$ia3$1@dont-email.me> Johann Beretta wrote: > On 5/2/20 10:33 AM, Eric Pozharski wrote: >> Yes, and it's intended behaviour. BTW, in defense of this >> abomination 'whois localhost' (and 'whois localhost.' too) refuses >> lookup at all. 'whois 127.0.0.1' doesn't serve anything reasonable >> either. So I figure 'localhost' is kindof free for grabs. > Yes. Per RFC 2006, Nope. RFC2006 is "The Definitions of Managed Objects for IP Mobility Support using SMIv2". > there are 4 reserved top level domains and 3 reserved second level > domains. Those 7 domains are excluded from the DNS root servers. They > can be assigned locally to resources but they will not resolve across > the DNS system. *SKIP* You are talking about RFC2606 "Reserved Top Level DNS Names". No, neither resolving nor serving across the fence was ever a point of this endeavour. Also, RFC6761 "Special-Use Domain Names" -- is worth reading. Just spotted this gem (in support of The Endeavour) 5. Authoritative DNS servers SHOULD recognize these names as special and SHOULD, by default, generate immediate negative responses for all such queries, unless explicitly configured by the administrator to give positive answers for private-address reverse-mapping names. Also, doesn't mention 127.in-addr.arpa. . Quality? > example.com example.net example.org are the three second level > domains. Totally resolvable. IP is 199.43.135.53 . *CUT* -- Torvalds' goal for Linux is very simple: World Domination Stallman's goal for GNU is even simpler: Freedom
Back to comp.os.linux.networking | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-01 00:03 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Grant Taylor <gtaylor@tnetconsulting.net> - 2020-04-30 21:54 -0600
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-02 20:02 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Grant Taylor <gtaylor@tnetconsulting.net> - 2020-05-03 11:35 -0600
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Johann Beretta <beretta@nun-ya-bizness.com> - 2020-05-01 10:59 -0700
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-02 20:33 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Johann Beretta <beretta@nun-ya-bizness.com> - 2020-05-02 22:00 -0700
Re: non-autoritative localhost, 1..12 sacle, how bad is it? harri@kallio.tunk.org (Harri) - 2020-05-03 12:11 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Johann Beretta <beretta@nun-ya-bizness.com> - 2020-05-04 20:46 -0700
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-03 16:53 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Johann Beretta <beretta@nun-ya-bizness.com> - 2020-05-04 20:50 -0700
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-06 18:15 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? "Carlos E.R." <robin_listas@es.invalid> - 2020-05-01 23:19 +0200
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-02 20:10 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? "Carlos E.R." <robin_listas@es.invalid> - 2020-05-03 15:21 +0200
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-04 18:17 +0300
Re: non-autoritative localhost, 1..12 sacle, how bad is it? "Carlos E.R." <robin_listas@es.invalid> - 2020-05-03 15:34 +0200
Re: non-autoritative localhost, 1..12 sacle, how bad is it? Eric Pozharski <whynot@pozharski.name> - 2020-05-04 18:14 +0300
csiph-web