Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1543146
| From | Daniel Micay <danielmicay@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant |
| Date | 2016-12-16 01:30 +0100 |
| Message-ID | <sOOzo-4lr-11@gated-at.bofh.it> (permalink) |
| References | (3 earlier) <sOoOB-49J-17@gated-at.bofh.it> <sOItX-km-9@gated-at.bofh.it> <sOLi9-23N-1@gated-at.bofh.it> <sOLBw-2r7-23@gated-at.bofh.it> <sOOg1-4cX-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
> So for statics, I think `static const char *` wins due to allowing > merging (although it doesn't matter here). For non-statics, you end up > with extra pointer constants. Those could get removed, but Linux > doesn't > have -fvisibility=hidden and I'm not sure how clever linkers are. > Maybe > setting up -fvisibility=hidden to work with monolithic non-module- > enabled builds could actually be realistic. Expect it'd remove a fair > bit of bloat but not sure how much would need to be marked as non- > hidden > other than the userspace ABI. -fvisibility=hidden + LTO would be really awesome though, since that doesn't depend on the cleverness of linkers. So much that could be ripped out of real world monolithic builds. Kinda getting off-topic now though. LTO is pretty scary from a security perspective due to how much worse undefined behavior that was previously harmless can get.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 19:50 +0100
[PATCH 1/4] kmod: make usermodehelper path a const string Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
[PATCH 3/4] Make static usermode helper binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:20 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Rich Felker <dalias@libc.org> - 2016-12-14 21:40 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Greg KH <greg@kroah.com> - 2016-12-14 22:00 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Greg KH <greg@kroah.com> - 2016-12-15 19:00 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-15 22:00 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-15 22:20 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-16 01:10 +0100
Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-16 01:30 +0100
[RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
Re: [RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Kees Cook <keescook@chromium.org> - 2016-12-14 21:40 +0100
Re: [RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 22:10 +0100
[PATCH 2/4] drbd: rename "usermode_helper" to "drbd_usermode_helper" Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" Mark Rutland <mark.rutland@arm.com> - 2016-12-14 20:30 +0100
Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" Kees Cook <keescook@chromium.org> - 2016-12-14 21:20 +0100
Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 22:30 +0100
Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-12-15 00:20 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" NeilBrown <neilb@suse.com> - 2016-12-16 02:10 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-16 14:00 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-19 14:40 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-20 10:30 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-20 11:30 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-20 11:40 +0100
Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-20 11:50 +0100
csiph-web