Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1542132

Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant

From Greg KH <gregkh@linuxfoundation.org>
Newsgroups linux.kernel
Subject Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper binaries constant
Date 2016-12-14 20:20 +0100
Message-ID <sOnfQ-2vz-7@gated-at.bofh.it> (permalink)
References <sOmMO-1X4-21@gated-at.bofh.it> <sOmWt-229-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Dec 14, 2016 at 10:50:52AM -0800, Greg KH wrote:
> 
> There are a number of usermode helper binaries that are "hard coded" in
> the kernel today, so mark them as "const" to make it harder for someone
> to change where the variables point to.
> 
> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> ---
>  drivers/macintosh/windfarm_core.c          | 2 +-
>  drivers/net/hamradio/baycom_epp.c          | 2 +-
>  drivers/pnp/pnpbios/core.c                 | 5 +++--
>  drivers/staging/greybus/svc_watchdog.c     | 4 ++--
>  drivers/staging/rtl8192e/rtl8192e/rtl_dm.c | 6 +++---
>  fs/nfsd/nfs4layouts.c                      | 6 ++++--
>  security/keys/request_key.c                | 7 ++++---
>  7 files changed, 18 insertions(+), 14 deletions(-)
> 
> diff --git a/drivers/macintosh/windfarm_core.c b/drivers/macintosh/windfarm_core.c
> index 465d770ab0bb..1b317cbb73cf 100644
> --- a/drivers/macintosh/windfarm_core.c
> +++ b/drivers/macintosh/windfarm_core.c
> @@ -74,7 +74,7 @@ static inline void wf_notify(int event, void *param)
>  
>  static int wf_critical_overtemp(void)
>  {
> -	static char * critical_overtemp_path = "/sbin/critical_overtemp";
> +	static const char * critical_overtemp_path = "/sbin/critical_overtemp";
>  	char *argv[] = { critical_overtemp_path, NULL };
>  	static char *envp[] = { "HOME=/",
>  				"TERM=linux",

Doh, minor compiler warnings for this one, and others in this patch,
I'll fix them up...

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 19:50 +0100
  [PATCH 1/4] kmod: make usermodehelper path a const string Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
  [PATCH 3/4] Make static usermode helper binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
    Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:20 +0100
    Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Rich Felker <dalias@libc.org> - 2016-12-14 21:40 +0100
      Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Greg KH <greg@kroah.com> - 2016-12-14 22:00 +0100
        Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Greg KH <greg@kroah.com> - 2016-12-15 19:00 +0100
          Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-15 22:00 +0100
            Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Greg KH <gregkh@linuxfoundation.org> - 2016-12-15 22:20 +0100
              Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-16 01:10 +0100
                Re: [kernel-hardening] [PATCH 3/4] Make static usermode helper  binaries constant Daniel Micay <danielmicay@gmail.com> - 2016-12-16 01:30 +0100
  [RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
    Re: [RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Kees Cook <keescook@chromium.org> - 2016-12-14 21:40 +0100
      Re: [RFC 4/4] Introduce CONFIG_READONLY_USERMODEHELPER Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 22:10 +0100
  [PATCH 2/4] drbd: rename "usermode_helper" to "drbd_usermode_helper" Greg KH <gregkh@linuxfoundation.org> - 2016-12-14 20:00 +0100
  Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more  "safe" Mark Rutland <mark.rutland@arm.com> - 2016-12-14 20:30 +0100
    Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" Kees Cook <keescook@chromium.org> - 2016-12-14 21:20 +0100
  Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more "safe" "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 22:30 +0100
    Re: [kernel-hardening] [RFC 0/4] make call_usermodehelper a bit more  "safe" Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-12-15 00:20 +0100
  Re: [RFC 0/4] make call_usermodehelper a bit more "safe" NeilBrown <neilb@suse.com> - 2016-12-16 02:10 +0100
    Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-16 14:00 +0100
      Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-19 14:40 +0100
        Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-20 10:30 +0100
          Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-20 11:30 +0100
            Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Jiri Kosina <jikos@kernel.org> - 2016-12-20 11:40 +0100
              Re: [RFC 0/4] make call_usermodehelper a bit more "safe" Greg KH <gregkh@linuxfoundation.org> - 2016-12-20 11:50 +0100

csiph-web