Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1370109
| From | Eric Biggers <ebiggers3@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 06/13] fscrypto: crypto_alloc_skcipher() always returns an ERR_PTR(), never NULL |
| Date | 2016-04-03 07:30 +0200 |
| Message-ID | <rjILN-748-29@gated-at.bofh.it> (permalink) |
| References | <rjILL-748-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Signed-off-by: Eric Biggers <ebiggers3@gmail.com>
---
fs/crypto/keyinfo.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/fs/crypto/keyinfo.c b/fs/crypto/keyinfo.c
index 33296c0..cb06351 100644
--- a/fs/crypto/keyinfo.c
+++ b/fs/crypto/keyinfo.c
@@ -208,8 +208,8 @@ retry:
goto out;
got_key:
ctfm = crypto_alloc_skcipher(cipher_str, 0, 0);
- if (!ctfm || IS_ERR(ctfm)) {
- res = ctfm ? PTR_ERR(ctfm) : -ENOMEM;
+ if (IS_ERR(ctfm)) {
+ res = PTR_ERR(ctfm);
printk(KERN_DEBUG
"%s: error %d (inode %u) allocating crypto tfm\n",
__func__, res, (unsigned) inode->i_ino);
--
2.7.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/13] fscrypto: cleanups and fixes Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 12/13] fscrypto: require write access to mount to set encryption policy Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 04/13] fscrypto: return bool instead of int where appropriate Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 10/13] fscrypto: restrict setting new policy to empty files and directories only Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 05/13] fscrypto: comment improvements and fixes Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 07/13] fscrypto: simplify building key descriptor string Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 02/13] fscrypto: rename some functions for clarity Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
Re: [PATCH 02/13] fscrypto: rename some functions for clarity Theodore Ts'o <tytso@mit.edu> - 2016-04-03 09:50 +0200
[PATCH 11/13] fscrypto: restrict setting encryption policy to inode owner Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 08/13] fscrypto: use standard macros from kernel.h Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 09/13] fscrypto: make fname_encrypt() actually return length of ciphertext Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 13/13] fscrypto: improve error handling in fscrypt_set_policy() Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 06/13] fscrypto: crypto_alloc_skcipher() always returns an ERR_PTR(), never NULL Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
[PATCH 03/13] fscrypto: rename functions to load and unload inode encryption info Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
csiph-web