Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1370098

[PATCH 00/13] fscrypto: cleanups and fixes

From Eric Biggers <ebiggers3@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 00/13] fscrypto: cleanups and fixes
Date 2016-04-03 07:30 +0200
Message-ID <rjILL-748-3@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patchset includes various cleanups for the new filesystem encryption
code as well as some bug fixes for the FS_IOC_SET_ENCRYPTION_POLICY ioctl.

Eric Biggers (13):
  fscrypto: remove unnecessary includes
  fscrypto: rename some functions for clarity
  fscrypto: rename functions to load and unload inode encryption info
  fscrypto: return bool instead of int where appropriate
  fscrypto: comment improvements and fixes
  fscrypto: crypto_alloc_skcipher() always returns an ERR_PTR(), never
    NULL
  fscrypto: simplify building key descriptor string
  fscrypto: use standard macros from kernel.h
  fscrypto: make fname_encrypt() actually return length of ciphertext
  fscrypto: restrict setting new policy to empty files and directories
    only
  fscrypto: restrict setting encryption policy to inode owner
  fscrypto: require write access to mount to set encryption policy
  fscrypto: improve error handling in fscrypt_set_policy()

 fs/crypto/crypto.c       |  25 +++++----
 fs/crypto/fname.c        |  72 ++++++++++++++++----------
 fs/crypto/keyinfo.c      |  47 ++++++++---------
 fs/crypto/policy.c       | 131 +++++++++++++++++++++++++++--------------------
 fs/f2fs/dir.c            |   4 +-
 fs/f2fs/f2fs.h           |   6 +--
 fs/f2fs/file.c           |  10 ++--
 fs/f2fs/inode.c          |   2 +-
 fs/f2fs/namei.c          |  10 ++--
 fs/f2fs/super.c          |   2 +-
 include/linux/fscrypto.h |  81 +++++++++++++++++++++--------
 11 files changed, 236 insertions(+), 154 deletions(-)

-- 
2.7.4

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 00/13] fscrypto: cleanups and fixes Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 12/13] fscrypto: require write access to mount to set encryption policy Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 04/13] fscrypto: return bool instead of int where appropriate Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 10/13] fscrypto: restrict setting new policy to empty files and directories only Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 05/13] fscrypto: comment improvements and fixes Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 07/13] fscrypto: simplify building key descriptor string Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 02/13] fscrypto: rename some functions for clarity Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
    Re: [PATCH 02/13] fscrypto: rename some functions for clarity Theodore Ts'o <tytso@mit.edu> - 2016-04-03 09:50 +0200
  [PATCH 11/13] fscrypto: restrict setting encryption policy to inode owner Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 08/13] fscrypto: use standard macros from kernel.h Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 09/13] fscrypto: make fname_encrypt() actually return length of ciphertext Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 13/13] fscrypto: improve error handling in fscrypt_set_policy() Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 06/13] fscrypto: crypto_alloc_skcipher() always returns an ERR_PTR(), never NULL Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200
  [PATCH 03/13] fscrypto: rename functions to load and unload inode encryption info Eric Biggers <ebiggers3@gmail.com> - 2016-04-03 07:30 +0200

csiph-web