Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1353378

Re: [PATCH 01/11] rxrpc: Add a common object cache

From David Miller <davem@davemloft.net>
Newsgroups linux.kernel
Subject Re: [PATCH 01/11] rxrpc: Add a common object cache
Date 2016-03-08 21:20 +0100
Message-ID <rawgO-5Tc-13@gated-at.bofh.it> (permalink)
References <ra4DU-46c-19@gated-at.bofh.it> <rac8p-y1-1@gated-at.bofh.it> <rapyH-1hW-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: David Howells <dhowells@redhat.com>
Date: Tue, 08 Mar 2016 13:02:28 +0000

> David Howells <dhowells@redhat.com> wrote:
> 
>> Does it make sense to maintain a FIFO list of connections (though this would
>> mean potentially taking a spinlock every time I get a packet)?
> 
> It occurs to me that only inactive connections would need to be on an LRU
> list.  Any connection with packets or active calls to deal with wouldn't be on
> the list.

In that kind of scheme you have to decide if it's possible to elide a
response in order to intentionally keep objects off the "inactive" LRU
list.  I bet there is.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/11] RxRPC: Rewrite part 2 David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
  [PATCH 11/11] rxrpc: Rename rxrpc_UDP_error_report() to  rxrpc_error_report() David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
  [PATCH 07/11] rxrpc: Rename ar-peer.c to peer-object.c David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
  [PATCH 05/11] rxrpc: procfs file to list local endpoints David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
  [PATCH 02/11] rxrpc: Do procfs lists through objcache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
  [PATCH 09/11] rxrpc: Add /proc/net/rxrpc_peers to display the known  remote endpoints David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
  [PATCH 06/11] rxrpc: Rename ar-local.c to local-event.c David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
  [PATCH 10/11] rxrpc: Rename ar-error.c to peer-event.c David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
  [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
    Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-07 19:50 +0100
      Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-07 23:50 +0100
        Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 05:10 +0100
          Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 12:50 +0100
            Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 14:10 +0100
              Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 21:20 +0100
            Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 21:20 +0100
              Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 22:20 +0100
                Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-09 04:10 +0100
  [PATCH 04/11] rxrpc: Implement local endpoint cache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
  [PATCH 03/11] rxrpc: Separate local endpoint object handling out  into its own file David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100

csiph-web