Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1352605
| From | David Miller <davem@davemloft.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 01/11] rxrpc: Add a common object cache |
| Date | 2016-03-08 05:10 +0100 |
| Message-ID | <rah86-493-1@gated-at.bofh.it> (permalink) |
| References | <ra4ue-42s-17@gated-at.bofh.it> <ra4DU-46c-19@gated-at.bofh.it> <rac8p-y1-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: David Howells <dhowells@redhat.com>
Date: Mon, 07 Mar 2016 22:45:14 +0000
> David Miller <davem@davemloft.net> wrote:
>
>> I know you put a lot of time and effort into this, but I want to strongly
>> recommend against a garbage collected hash table for anything whatsoever.
>>
>> Especially if the given objects are in some way created/destroyed/etc. by
>> operations triggerable remotely.
>>
>> This can be DoS'd quite trivially, and that's why we have removed the ipv4
>> routing cache which did the same.
>
> Hmmm... You have a point. What would you suggest instead? At least with the
> common object cache code I have, I might be able to just change that.
Objects that are used for correct operation have no easily recyclable
property, you must hold onto them. There has to be a set of resources
held and consumed at both endpoints for it to work properly ("I can't
DoS you without DoS'ing myself").
Where reclaimable tables work is for stuff that is near zero cost to
reconstitute. A good example is the TCP metrics table. When a TCP
metrics entry is reclaimed, it's not like we have to renegotiate a
security context when we try to talk to that end-host again.
If the concept of these open-ended objects is a fundamental aspect of
the protocol.... that's a serious shortcoming of RXRPC.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/11] RxRPC: Rewrite part 2 David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
[PATCH 11/11] rxrpc: Rename rxrpc_UDP_error_report() to rxrpc_error_report() David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
[PATCH 07/11] rxrpc: Rename ar-peer.c to peer-object.c David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
[PATCH 05/11] rxrpc: procfs file to list local endpoints David Howells <dhowells@redhat.com> - 2016-03-07 15:40 +0100
[PATCH 02/11] rxrpc: Do procfs lists through objcache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
[PATCH 09/11] rxrpc: Add /proc/net/rxrpc_peers to display the known remote endpoints David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
[PATCH 06/11] rxrpc: Rename ar-local.c to local-event.c David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
[PATCH 10/11] rxrpc: Rename ar-error.c to peer-event.c David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
[PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-07 19:50 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-07 23:50 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 05:10 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 12:50 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 14:10 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 21:20 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-08 21:20 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Howells <dhowells@redhat.com> - 2016-03-08 22:20 +0100
Re: [PATCH 01/11] rxrpc: Add a common object cache David Miller <davem@davemloft.net> - 2016-03-09 04:10 +0100
[PATCH 04/11] rxrpc: Implement local endpoint cache David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
[PATCH 03/11] rxrpc: Separate local endpoint object handling out into its own file David Howells <dhowells@redhat.com> - 2016-03-07 15:50 +0100
csiph-web