Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1448055

[PATCH 01/13] rapidio: Remove unnecessary 0x prefixes before %pa extension uses

From Alexandre Bounine <alexandre.bounine@idt.com>
Newsgroups linux.kernel
Subject [PATCH 01/13] rapidio: Remove unnecessary 0x prefixes before %pa extension uses
Date 2016-07-21 20:30 +0200
Message-ID <rXqTo-2Jr-21@gated-at.bofh.it> (permalink)
References <rXqJI-2G4-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Joe Perches <joe@perches.com>

This is RapidIO part of the original patch submitted by Joe Perches.
(see: https://lkml.org/lkml/2016/3/5/19)

Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code
to special_hex_number()") %pa uses have been output with a 0x prefix.

These 0x prefixes in the formats are unnecessary.

Signed-off-by: Joe Perches <joe@perches.com>
Signed-off-by: Alexandre Bounine <alexandre.bounine@idt.com>
Cc: Matt Porter <mporter@kernel.crashing.org>
Cc: Andre van Herk <andre.van.herk@prodrive-technologies.com>
Cc: Barry Wood <barry.wood@idt.com>
Cc: linux-kernel@vger.kernel.org
---
 drivers/rapidio/devices/rio_mport_cdev.c |    4 ++--
 drivers/rapidio/devices/tsi721.c         |    8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/rapidio/devices/rio_mport_cdev.c b/drivers/rapidio/devices/rio_mport_cdev.c
index e165b7c..de0c692 100644
--- a/drivers/rapidio/devices/rio_mport_cdev.c
+++ b/drivers/rapidio/devices/rio_mport_cdev.c
@@ -2242,7 +2242,7 @@ static void mport_mm_open(struct vm_area_struct *vma)
 {
 	struct rio_mport_mapping *map = vma->vm_private_data;
 
-rmcd_debug(MMAP, "0x%pad", &map->phys_addr);
+	rmcd_debug(MMAP, "%pad", &map->phys_addr);
 	kref_get(&map->ref);
 }
 
@@ -2250,7 +2250,7 @@ static void mport_mm_close(struct vm_area_struct *vma)
 {
 	struct rio_mport_mapping *map = vma->vm_private_data;
 
-rmcd_debug(MMAP, "0x%pad", &map->phys_addr);
+	rmcd_debug(MMAP, "%pad", &map->phys_addr);
 	mutex_lock(&map->md->buf_mutex);
 	kref_put(&map->ref, mport_release_mapping);
 	mutex_unlock(&map->md->buf_mutex);
diff --git a/drivers/rapidio/devices/tsi721.c b/drivers/rapidio/devices/tsi721.c
index b5b4556..4c20e99 100644
--- a/drivers/rapidio/devices/tsi721.c
+++ b/drivers/rapidio/devices/tsi721.c
@@ -1101,7 +1101,7 @@ static int tsi721_rio_map_inb_mem(struct rio_mport *mport, dma_addr_t lstart,
 		ibw_start = lstart & ~(ibw_size - 1);
 
 		tsi_debug(IBW, &priv->pdev->dev,
-			"Direct (RIO_0x%llx -> PCIe_0x%pad), size=0x%x, ibw_start = 0x%llx",
+			"Direct (RIO_0x%llx -> PCIe_%pad), size=0x%x, ibw_start = 0x%llx",
 			rstart, &lstart, size, ibw_start);
 
 		while ((lstart + size) > (ibw_start + ibw_size)) {
@@ -1120,7 +1120,7 @@ static int tsi721_rio_map_inb_mem(struct rio_mport *mport, dma_addr_t lstart,
 
 	} else {
 		tsi_debug(IBW, &priv->pdev->dev,
-			"Translated (RIO_0x%llx -> PCIe_0x%pad), size=0x%x",
+			"Translated (RIO_0x%llx -> PCIe_%pad), size=0x%x",
 			rstart, &lstart, size);
 
 		if (!is_power_of_2(size) || size < 0x1000 ||
@@ -1215,7 +1215,7 @@ static int tsi721_rio_map_inb_mem(struct rio_mport *mport, dma_addr_t lstart,
 	priv->ibwin_cnt--;
 
 	tsi_debug(IBW, &priv->pdev->dev,
-		"Configured IBWIN%d (RIO_0x%llx -> PCIe_0x%pad), size=0x%llx",
+		"Configured IBWIN%d (RIO_0x%llx -> PCIe_%pad), size=0x%llx",
 		i, ibw_start, &loc_start, ibw_size);
 
 	return 0;
@@ -1237,7 +1237,7 @@ static void tsi721_rio_unmap_inb_mem(struct rio_mport *mport,
 	int i;
 
 	tsi_debug(IBW, &priv->pdev->dev,
-		"Unmap IBW mapped to PCIe_0x%pad", &lstart);
+		"Unmap IBW mapped to PCIe_%pad", &lstart);
 
 	/* Search for matching active inbound translation window */
 	for (i = 0; i < TSI721_IBWIN_NUM; i++) {
-- 
1.7.8.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/13] RapidIO subsystem updates Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:20 +0200
  [PATCH 08/13] rapidio: fix error handling in mbox request/release functions Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 09/13] rapidio/idt_gen2: fix locking warning Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 11/13] rapidio: modify for rev.3 specification changes Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 12/13] powerpc/fsl_rio: apply changes for RIO spec rev 3 Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 05/13] rapidio/tsi721: add PCIe MRRS override parameter Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 06/13] rapidio/tsi721: add messaging mbox selector parameter Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  [PATCH 01/13] rapidio: Remove unnecessary 0x prefixes before %pa extension uses Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:30 +0200
  Re: [PATCH 13/13] rapidio/switches: add driver for IDT gen3  switches Andrew Morton <akpm@linux-foundation.org> - 2016-07-21 20:40 +0200
    RE: [PATCH 13/13] rapidio/switches: add driver for IDT gen3 switches "Bounine, Alexandre" <Alexandre.Bounine@idt.com> - 2016-07-21 21:10 +0200
      Re: [PATCH 13/13] rapidio/switches: add driver for IDT gen3  switches Andrew Morton <akpm@linux-foundation.org> - 2016-07-21 21:10 +0200
  [PATCH 13/13] rapidio/switches: add driver for IDT gen3 switches Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:40 +0200
  [PATCH 10/13] rapidio: change inbound window size type to u64 Alexandre Bounine <alexandre.bounine@idt.com> - 2016-07-21 20:40 +0200

csiph-web