Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1437983

[PATCH 07/12] lkdtm: remove intentional off-by-one array access

From Kees Cook <keescook@chromium.org>
Newsgroups linux.kernel
Subject [PATCH 07/12] lkdtm: remove intentional off-by-one array access
Date 2016-07-07 00:40 +0200
Message-ID <rS3E5-6Mf-5@gated-at.bofh.it> (permalink)
References <rS3E5-6Mf-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


There wasn't a good reason for keeping the enum and the names out of sync
by 1 position just to avoid "NONE" and "INVALID" from being in the string
lists.

Signed-off-by: Kees Cook <keescook@chromium.org>
---
 drivers/misc/lkdtm_core.c | 16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)

diff --git a/drivers/misc/lkdtm_core.c b/drivers/misc/lkdtm_core.c
index e0f10131511f..4f9d2f32c88b 100644
--- a/drivers/misc/lkdtm_core.c
+++ b/drivers/misc/lkdtm_core.c
@@ -111,6 +111,7 @@ enum ctype {
 };
 
 static char* cp_name[] = {
+	"INVALID",
 	"INT_HARDWARE_ENTRY",
 	"INT_HW_IRQ_EN",
 	"INT_TASKLET_ENTRY",
@@ -123,6 +124,7 @@ static char* cp_name[] = {
 };
 
 static char* cp_type[] = {
+	"NONE",
 	"PANIC",
 	"BUG",
 	"WARNING",
@@ -257,7 +259,7 @@ static enum ctype parse_cp_type(const char *what, size_t count)
 
 	for (i = 0; i < ARRAY_SIZE(cp_type); i++) {
 		if (!strcmp(what, cp_type[i]))
-			return i + 1;
+			return i;
 	}
 
 	return CT_NONE;
@@ -266,9 +268,9 @@ static enum ctype parse_cp_type(const char *what, size_t count)
 static const char *cp_type_to_str(enum ctype type)
 {
 	if (type == CT_NONE || type < 0 || type > ARRAY_SIZE(cp_type))
-		return "None";
+		return "NONE";
 
-	return cp_type[type - 1];
+	return cp_type[type];
 }
 
 static const char *cp_name_to_str(enum cname name)
@@ -276,7 +278,7 @@ static const char *cp_name_to_str(enum cname name)
 	if (name == CN_INVALID || name < 0 || name > ARRAY_SIZE(cp_name))
 		return "INVALID";
 
-	return cp_name[name - 1];
+	return cp_name[name];
 }
 
 
@@ -304,9 +306,13 @@ static int lkdtm_parse_commandline(void)
 	if (cptype == CT_NONE)
 		return -EINVAL;
 
+	/* Refuse INVALID as a selectable crashpoint name. */
+	if (!strcmp(cpoint_name, "INVALID"))
+		return -EINVAL;
+
 	for (i = 0; i < ARRAY_SIZE(cp_name); i++) {
 		if (!strcmp(cpoint_name, cp_name[i])) {
-			cpoint = i + 1;
+			cpoint = i;
 			return 0;
 		}
 	}
-- 
2.7.4

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/12] lkdtm: use struct arrays instead of enums Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 07/12] lkdtm: remove intentional off-by-one array access Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 09/12] lkdtm: rename globals for clarity Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 05/12] lkdtm: split heap corruption tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 04/12] lkdtm: split memory permissions tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 08/12] lkdtm: rename "count" to "crash_count" Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 03/12] lkdtm: split usercopy tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 06/12] lkdtm: split remaining logic bug tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 01/12] lkdtm: add usercopy test for blocking kernel text Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 11/12] lkdtm: move jprobe entry points to start of source Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 10/12] lkdtm: reorganize module paramaters Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 02/12] lkdtm: drop "alloc_size" parameter Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
  [PATCH 12/12] lkdtm: use struct arrays instead of enums Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200

csiph-web