Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1437982
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/12] lkdtm: use struct arrays instead of enums |
| Date | 2016-07-07 00:40 +0200 |
| Message-ID | <rS3E5-6Mf-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This is a large refactoring of lkdtm to make it easier to add new tests, and breaks up tests into separate source files. Final results are the same, but uses struct arrays instead of enums. -Kees
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/12] lkdtm: use struct arrays instead of enums Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 07/12] lkdtm: remove intentional off-by-one array access Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 09/12] lkdtm: rename globals for clarity Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 05/12] lkdtm: split heap corruption tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 04/12] lkdtm: split memory permissions tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 08/12] lkdtm: rename "count" to "crash_count" Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 03/12] lkdtm: split usercopy tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 06/12] lkdtm: split remaining logic bug tests to separate file Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 01/12] lkdtm: add usercopy test for blocking kernel text Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 11/12] lkdtm: move jprobe entry points to start of source Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 10/12] lkdtm: reorganize module paramaters Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 02/12] lkdtm: drop "alloc_size" parameter Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200 [PATCH 12/12] lkdtm: use struct arrays instead of enums Kees Cook <keescook@chromium.org> - 2016-07-07 00:40 +0200
csiph-web