Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1344896

[PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant

From John Stultz <john.stultz@linaro.org>
Newsgroups linux.kernel
Subject [PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant
Date 2016-02-27 04:20 +0100
Message-ID <r6DAd-53s-9@gated-at.bofh.it> (permalink)
References <r6DAd-53s-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Alexander Kuleshov <kuleshovmail@gmail.com>

The CLOCKSOURCE_MASK(32) macro expands to the same value, but
makes code more readable.

Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Prarit Bhargava <prarit@redhat.com>
Cc: Richard Cochran <richardcochran@gmail.com>
Cc: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 kernel/time/jiffies.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/time/jiffies.c b/kernel/time/jiffies.c
index 347fecf..555e21f 100644
--- a/kernel/time/jiffies.c
+++ b/kernel/time/jiffies.c
@@ -68,7 +68,7 @@ static struct clocksource clocksource_jiffies = {
 	.name		= "jiffies",
 	.rating		= 1, /* lowest valid rating*/
 	.read		= jiffies_read,
-	.mask		= 0xffffffff, /*32bits*/
+	.mask		= CLOCKSOURCE_MASK(32),
 	.mult		= NSEC_PER_JIFFY << JIFFIES_SHIFT, /* details above */
 	.shift		= JIFFIES_SHIFT,
 	.max_cycles	= 10,
-- 
1.9.1

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant John Stultz <john.stultz@linaro.org> - 2016-02-27 04:20 +0100
  [tip:timers/core] jiffies: Use CLOCKSOURCE_MASK instead of constant tip-bot for Alexander Kuleshov <tipbot@zytor.com> - 2016-02-27 09:10 +0100

csiph-web