Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1344896 > unrolled thread

[PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant

Started byJohn Stultz <john.stultz@linaro.org>
First post2016-02-27 04:20 +0100
Last post2016-02-27 09:10 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant John Stultz <john.stultz@linaro.org> - 2016-02-27 04:20 +0100
    [tip:timers/core] jiffies: Use CLOCKSOURCE_MASK instead of constant tip-bot for Alexander Kuleshov <tipbot@zytor.com> - 2016-02-27 09:10 +0100

#1344896 — [PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant

FromJohn Stultz <john.stultz@linaro.org>
Date2016-02-27 04:20 +0100
Subject[PATCH 2/2] jiffies: use CLOCKSOURCE_MASK instead of constant
Message-ID<r6DAd-53s-9@gated-at.bofh.it>
From: Alexander Kuleshov <kuleshovmail@gmail.com>

The CLOCKSOURCE_MASK(32) macro expands to the same value, but
makes code more readable.

Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Prarit Bhargava <prarit@redhat.com>
Cc: Richard Cochran <richardcochran@gmail.com>
Cc: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 kernel/time/jiffies.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/time/jiffies.c b/kernel/time/jiffies.c
index 347fecf..555e21f 100644
--- a/kernel/time/jiffies.c
+++ b/kernel/time/jiffies.c
@@ -68,7 +68,7 @@ static struct clocksource clocksource_jiffies = {
 	.name		= "jiffies",
 	.rating		= 1, /* lowest valid rating*/
 	.read		= jiffies_read,
-	.mask		= 0xffffffff, /*32bits*/
+	.mask		= CLOCKSOURCE_MASK(32),
 	.mult		= NSEC_PER_JIFFY << JIFFIES_SHIFT, /* details above */
 	.shift		= JIFFIES_SHIFT,
 	.max_cycles	= 10,
-- 
1.9.1

[toc] | [next] | [standalone]


#1344943 — [tip:timers/core] jiffies: Use CLOCKSOURCE_MASK instead of constant

Fromtip-bot for Alexander Kuleshov <tipbot@zytor.com>
Date2016-02-27 09:10 +0100
Subject[tip:timers/core] jiffies: Use CLOCKSOURCE_MASK instead of constant
Message-ID<r6I6S-8vT-3@gated-at.bofh.it>
In reply to#1344896
Commit-ID:  232d26373d310a941ef2ab46e53ea62fe076ed13
Gitweb:     http://git.kernel.org/tip/232d26373d310a941ef2ab46e53ea62fe076ed13
Author:     Alexander Kuleshov <kuleshovmail@gmail.com>
AuthorDate: Fri, 26 Feb 2016 19:14:14 -0800
Committer:  Thomas Gleixner <tglx@linutronix.de>
CommitDate: Sat, 27 Feb 2016 08:55:31 +0100

jiffies: Use CLOCKSOURCE_MASK instead of constant

The CLOCKSOURCE_MASK(32) macro expands to the same value, but
makes code more readable.

Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
Signed-off-by: John Stultz <john.stultz@linaro.org>
Cc: Prarit Bhargava <prarit@redhat.com>
Cc: Richard Cochran <richardcochran@gmail.com>
Link: http://lkml.kernel.org/r/1456542854-22104-3-git-send-email-john.stultz@linaro.org
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
 kernel/time/jiffies.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/time/jiffies.c b/kernel/time/jiffies.c
index 347fecf..555e21f 100644
--- a/kernel/time/jiffies.c
+++ b/kernel/time/jiffies.c
@@ -68,7 +68,7 @@ static struct clocksource clocksource_jiffies = {
 	.name		= "jiffies",
 	.rating		= 1, /* lowest valid rating*/
 	.read		= jiffies_read,
-	.mask		= 0xffffffff, /*32bits*/
+	.mask		= CLOCKSOURCE_MASK(32),
 	.mult		= NSEC_PER_JIFFY << JIFFIES_SHIFT, /* details above */
 	.shift		= JIFFIES_SHIFT,
 	.max_cycles	= 10,

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web