Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1260663
| From | Geliang Tang <geliangtang@163.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] zram: move init_done check to the beginning of disksize_store |
| Date | 2015-11-02 15:00 +0100 |
| Message-ID | <qqnOs-5Zc-29@gated-at.bofh.it> (permalink) |
| References | <qpFNo-45K-13@gated-at.bofh.it> <qqaxP-6iv-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Nov 02, 2015 at 08:43:58AM +0900, Sergey Senozhatsky wrote: > On (10/31/15 22:50), Geliang Tang wrote: > > > > If we set disksize when disksize has been set, we will get the following > > error report: "write error: Cannot allocate memory". This is because > > disksize_store fails at zram_meta_alloc. > > Those things are not connected, absolutely. zram_meta_alloc() can fail > even on un-initialized device. In any case disksize_store() does not end > up changing the state of the device and reports the error back, so I don't > see any real value in this change. Seems that we come across this change > something like once a year (this patch is not the first). Thanks for your reply. zram_meta_alloc() always fails on initialized device at debugfs_create_dir(): debugfs dir <zram0> creation failed zram: Error creating memory pool I think we should deal with this error. > > I believe it has to stay the way it is, see https://lkml.org/lkml/2014/2/27/674 Unlike above, this patch did not call zram_meta_alloc() in lock. So it would not cause the deed lock problem. Geliang Tang -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] zram: move init_done check to the beginning of disksize_store Geliang Tang <geliangtang@163.com> - 2015-10-31 16:00 +0100
Re: [PATCH] zram: move init_done check to the beginning of disksize_store Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2015-11-02 00:50 +0100
Re: [PATCH] zram: move init_done check to the beginning of disksize_store Geliang Tang <geliangtang@163.com> - 2015-11-02 15:00 +0100
Re: [PATCH] zram: move init_done check to the beginning of disksize_store Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2015-11-03 01:20 +0100
csiph-web