Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1261078

Re: [PATCH] zram: move init_done check to the beginning of disksize_store

From Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH] zram: move init_done check to the beginning of disksize_store
Date 2015-11-03 01:20 +0100
Message-ID <qqxuq-3IW-13@gated-at.bofh.it> (permalink)
References <qpFNo-45K-13@gated-at.bofh.it> <qqaxP-6iv-3@gated-at.bofh.it> <qqnOs-5Zc-29@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

[please don't trim the Cc list]

On (11/02/15 21:53), Geliang Tang wrote:
> > Those things are not connected, absolutely. zram_meta_alloc() can fail
> > even on un-initialized device. In any case disksize_store() does not end
> > up changing the state of the device and reports the error back, so I don't
> > see any real value in this change. Seems that we come across this change
> > something like once a year (this patch is not the first).
> 
> Thanks for your reply.
> 
> zram_meta_alloc() always fails on initialized device at debugfs_create_dir():
> debugfs dir <zram0> creation failed

Aha, so you are talking about calling disksize_store() on
	- already initialized device that
	- uses zsmalloc with
	- CONFIG_ZSMALLOC_STAT as an alacator

(zbud is not affected). that should have been mentioned in the commit message.


hm, does the patch _actually_ make it better? splitting a ->init_lock regions
is *never* a good idea. consider an un-initialized device.

CPU0							CPU1

down_read(&zram->init_lock);
if (init_done(zram))
	return -EBUSY;
up_read(&zram->init_lock);

					down_read(&zram->init_lock);
					if (init_done(zram))
						return -EBUSY;
					up_read(&zram->init_lock);

meta = zram_meta_alloc();
					meta = zram_meta_alloc();
comp = zcomp_create();
					comp = zcomp_create();
down_write(&zram->init_lock);
zram->meta = meta;
...
up_write(&zram->init_lock);

					down_write(&zram->init_lock);
					zram->meta = meta;
					...
					up_write(&zram->init_lock);


So the above code will return a "debugfs dir <zram0> creation failed"
IFF zsmalloc with CONFIG_ZSMALLOC_STAT enabled is being used (regardless the
effort). And it will totally succeed and lead to N (depending on the number of
concurrent disksize_store() calls) pool memory and zcomp_create memory leaks
otherwise. Because of this part:

---
        down_write(&zram->init_lock);
-       if (init_done(zram)) {
-               pr_info("Cannot change disksize for initialized device\n");
-               err = -EBUSY;
-               goto out_destroy_comp;
-       }
-
        init_waitqueue_head(&zram->io_done);
        atomic_set(&zram->refcount, 1);
        zram->meta = meta;
---


> zram: Error creating memory pool
> 
> I think we should deal with this error.

Is it so critical? I mean it does not break the existing device; we
print the error and keep the existing device fully functional. The
error line may be a bit misleading, which is another thing and can
be solved documenting the behavior, *for example*. (I just don't
really want to complicate the code for a corner case which doesn't
even break anything).

	-ss
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH] zram: move init_done check to the beginning of disksize_store Geliang Tang <geliangtang@163.com> - 2015-10-31 16:00 +0100
  Re: [PATCH] zram: move init_done check to the beginning of  disksize_store Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2015-11-02 00:50 +0100
    Re: [PATCH] zram: move init_done check to the beginning of  disksize_store Geliang Tang <geliangtang@163.com> - 2015-11-02 15:00 +0100
      Re: [PATCH] zram: move init_done check to the beginning of  disksize_store Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2015-11-03 01:20 +0100

csiph-web