Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1242557
| From | "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 16/22] arm64/debug: Make use of the system wide safe value |
| Date | 2015-10-08 18:00 +0200 |
| Message-ID | <qhlLP-81t-3@gated-at.bofh.it> (permalink) |
| References | <qghqV-5ar-3@gated-at.bofh.it> <qghqY-5ar-61@gated-at.bofh.it> <qhhoS-1PL-23@gated-at.bofh.it> <qhi1A-2A7-13@gated-at.bofh.it> <qhkZs-76Q-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 08/10/15 16:08, Catalin Marinas wrote:
> On Thu, Oct 08, 2015 at 12:56:28PM +0100, Suzuki K. Poulose wrote:
>> On 08/10/15 12:11, Catalin Marinas wrote:
>>> On Mon, Oct 05, 2015 at 06:02:05PM +0100, Suzuki K. Poulose wrote:
>>>> @@ -137,13 +138,17 @@ extern struct pmu perf_ops_bp;
>>>> /* Determine number of BRP registers available. */
>>>> static inline int get_num_brps(void)
>>>> {
>>>> - return ((read_cpuid(ID_AA64DFR0_EL1) >> 12) & 0xf) + 1;
>>>> + return 1 +
>>>> + cpuid_feature_extract_field(read_system_reg(SYS_ID_AA64DFR0_EL1),
>>>> + ID_AA64DFR0_BRPS_SHIFT);
>>>> }
>>>
>>> cpuid_feature_extract_field() is fine but we should we bother with
>>> read_system_reg vs just read_cpuid?
>>> Similar question for patch 17/22.
>>
>> Well, we would have already TAINTed the kernel, if these fields are different.
>> It is just the matter of, whether we want to provide the safer value on a tainted
>> kernel or not. I am open to suggestions.
>
> Ah, sorry, I mixed read_system_reg() with read_cpu_sysreg(). I think we
Oh, ok. I think we should rename it as you suggest below to avoid the
confusion.
> need to rename the latter as it gets confusing. Maybe something like
> read_native_sys_reg() or __raw_read_system_reg().
>
Thanks
Suzuki
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v2 16/22] arm64/debug: Make use of the system wide safe value Catalin Marinas <catalin.marinas@arm.com> - 2015-10-08 13:20 +0200
Re: [PATCH v2 16/22] arm64/debug: Make use of the system wide safe value "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-08 14:00 +0200
Re: [PATCH v2 16/22] arm64/debug: Make use of the system wide safe value Catalin Marinas <catalin.marinas@arm.com> - 2015-10-08 17:10 +0200
Re: [PATCH v2 16/22] arm64/debug: Make use of the system wide safe value "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-08 18:00 +0200
csiph-web