Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1308472

[PATCH 3/5] drm/sysfs: use kobj_to_dev()

From Geliang Tang <geliangtang@163.com>
Newsgroups linux.kernel
Subject [PATCH 3/5] drm/sysfs: use kobj_to_dev()
Date 2016-01-13 15:50 +0100
Message-ID <qQuUh-15y-5@gated-at.bofh.it> (permalink)
References <qQuUh-15y-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Use kobj_to_dev() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/gpu/drm/drm_sysfs.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/drm_sysfs.c b/drivers/gpu/drm/drm_sysfs.c
index 0ca6410..d503f8e 100644
--- a/drivers/gpu/drm/drm_sysfs.c
+++ b/drivers/gpu/drm/drm_sysfs.c
@@ -240,7 +240,7 @@ static ssize_t edid_show(struct file *filp, struct kobject *kobj,
 			 struct bin_attribute *attr, char *buf, loff_t off,
 			 size_t count)
 {
-	struct device *connector_dev = container_of(kobj, struct device, kobj);
+	struct device *connector_dev = kobj_to_dev(kobj);
 	struct drm_connector *connector = to_drm_connector(connector_dev);
 	unsigned char *edid;
 	size_t size;
-- 
2.5.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/5] drm/i915: use hlist_for_each_entry Geliang Tang <geliangtang@163.com> - 2016-01-13 15:50 +0100
  [PATCH 3/5] drm/sysfs: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 15:50 +0100
    Re: [PATCH 3/5] drm/sysfs: use kobj_to_dev() Daniel Vetter <daniel@ffwll.ch> - 2016-01-13 16:50 +0100
  [PATCH 5/5] drm/radeon: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 16:00 +0100
    Re: [PATCH 5/5] drm/radeon: use kobj_to_dev() Alex Deucher <alexdeucher@gmail.com> - 2016-01-13 18:20 +0100
  [PATCH 2/5] drm/i915: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 16:00 +0100
    Re: [Intel-gfx] [PATCH 2/5] drm/i915: use kobj_to_dev() Daniel Vetter <daniel@ffwll.ch> - 2016-01-13 16:50 +0100
  Re: [Intel-gfx] [PATCH 1/5] drm/i915: use hlist_for_each_entry Chris Wilson <chris@chris-wilson.co.uk> - 2016-01-13 16:20 +0100

csiph-web