Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1308647
| From | Alex Deucher <alexdeucher@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 5/5] drm/radeon: use kobj_to_dev() |
| Date | 2016-01-13 18:20 +0100 |
| Message-ID | <qQxfu-2SP-25@gated-at.bofh.it> (permalink) |
| References | <qQuUh-15y-7@gated-at.bofh.it> <qQv3Y-19C-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jan 13, 2016 at 9:48 AM, Geliang Tang <geliangtang@163.com> wrote:
> Use kobj_to_dev() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@163.com>
Applied patches 4 and 5. thanks!
Alex
> ---
> drivers/gpu/drm/radeon/radeon_pm.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c
> index 59abebd..460c8f2 100644
> --- a/drivers/gpu/drm/radeon/radeon_pm.c
> +++ b/drivers/gpu/drm/radeon/radeon_pm.c
> @@ -713,7 +713,7 @@ static struct attribute *hwmon_attributes[] = {
> static umode_t hwmon_attributes_visible(struct kobject *kobj,
> struct attribute *attr, int index)
> {
> - struct device *dev = container_of(kobj, struct device, kobj);
> + struct device *dev = kobj_to_dev(kobj);
> struct radeon_device *rdev = dev_get_drvdata(dev);
> umode_t effective_mode = attr->mode;
>
> --
> 2.5.0
>
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/5] drm/i915: use hlist_for_each_entry Geliang Tang <geliangtang@163.com> - 2016-01-13 15:50 +0100
[PATCH 3/5] drm/sysfs: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 15:50 +0100
Re: [PATCH 3/5] drm/sysfs: use kobj_to_dev() Daniel Vetter <daniel@ffwll.ch> - 2016-01-13 16:50 +0100
[PATCH 5/5] drm/radeon: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 16:00 +0100
Re: [PATCH 5/5] drm/radeon: use kobj_to_dev() Alex Deucher <alexdeucher@gmail.com> - 2016-01-13 18:20 +0100
[PATCH 2/5] drm/i915: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-13 16:00 +0100
Re: [Intel-gfx] [PATCH 2/5] drm/i915: use kobj_to_dev() Daniel Vetter <daniel@ffwll.ch> - 2016-01-13 16:50 +0100
Re: [Intel-gfx] [PATCH 1/5] drm/i915: use hlist_for_each_entry Chris Wilson <chris@chris-wilson.co.uk> - 2016-01-13 16:20 +0100
csiph-web