Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1303894

Re: [PATCH v2 2/5] test: firmware_class: use kstrndup() where appropriate

From Shuah Khan <shuahkh@osg.samsung.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 2/5] test: firmware_class: use kstrndup() where appropriate
Date 2016-01-07 22:00 +0100
Message-ID <qOpP4-4VR-3@gated-at.bofh.it> (permalink)
References <qDVSi-65j-11@gated-at.bofh.it> <qDVSj-65j-35@gated-at.bofh.it>
Organization Samsung Open Source Group

Show all headers | View raw


On 12/09/2015 03:50 PM, Brian Norris wrote:
> We're essentially just doing an open-coded kstrndup(). The only
> differences are with what happens after the first '\0' character, but
> request_firmware() doesn't care about that.
> 
> Suggested-by: Kees Cook <keescook@chromium.org>
> Signed-off-by: Brian Norris <computersforpeace@gmail.com>
> ---

Thanks for fixing it. Applied to linux-kselftest next for 4.5-rc1.

thanks,
-- Shuah

-- 
Shuah Khan
Sr. Linux Kernel Developer
Open Source Innovation Group
Samsung Research America (Silicon Valley)
shuahkh@osg.samsung.com | (970) 217-8978

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH v2 2/5] test: firmware_class: use kstrndup() where  appropriate Shuah Khan <shuahkh@osg.samsung.com> - 2016-01-07 22:00 +0100

csiph-web