Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1297181

Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver

From Rob Herring <robh@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver
Date 2015-12-23 01:40 +0100
Message-ID <qIFDc-2Co-21@gated-at.bofh.it> (permalink)
References <qIr7c-1XX-11@gated-at.bofh.it> <qIr7c-1XX-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Dec 22, 2015 at 05:05:24PM +0800, Andy Yan wrote:
> add device tree bindings document for reboot-mode driver
> 
> Signed-off-by: Andy Yan <andy.yan@rock-chips.com>
> 
> ---
> 
> Changes in v1: None
> 
>  .../devicetree/bindings/misc/reboot-mode.txt       | 41 ++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/misc/reboot-mode.txt
> 
> diff --git a/Documentation/devicetree/bindings/misc/reboot-mode.txt b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> new file mode 100644
> index 0000000..082bc0c
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> @@ -0,0 +1,41 @@
> +Generic reboot mode communication driver

You're not describing a driver. It is a mapping of boot modes to values.
> +
> +This driver get reboot mode arguments from userspace

Coming from userspace is a Linuxism.

> +and stores it in special register or ram . Then the
> +bootloader will read it and take different action
> +according the argument stored.
> +
> +Required properties:
> +        - compatible = "reboot-mode" or other vendor compatible string;
> +
> +Each mode is represented as a sub-node of reboot_mode:
> +
> +Subnode required properties:
> +        - linux,mode: reboot mode command,such as "loader","recovery", "fastboot".
> +        - linux,magic: magic number for the mode, this is vendor specific.
> +
> +example:
> +	reboot_mode {
> +		compatible = "rockchip,reboot-mode";
> +		rockchip,regmap = <&pmu>;
> +		offset = <0x40>;
> +		loader {
> +			linux,mode = "loader";
> +			linux,magic = <0x5242C301>;
> +		};

These can be much more simply expressed as:

loader = <0x5242c301>;

I would like to see the property names here standardized as much as
possible. I'm not sure if we can define the properties as a u32 or need
some flexibility here.

Rob
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:10 +0100
  [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:10 +0100
    Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode  driver Rob Herring <robh@kernel.org> - 2015-12-23 01:40 +0100
      Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver Moritz Fischer <moritz.fischer@ettus.com> - 2015-12-23 09:40 +0100
      Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode  driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-23 10:10 +0100
  [PATCH v1 4/6] soc: rockchip: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 3/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 5/6] ARM: dts: rockchip: add reboot-mode node Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
    Re: [PATCH v1 5/6] ARM: dts: rockchip: add reboot-mode node Heiko Stübner <heiko@sntech.de> - 2015-12-22 12:30 +0100
  [PATCH v1 2/6] dt-bindings: soc: add document for rockchip reboot-mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 6/6] ARM64: dts: rockchip: add reboot-mode node Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:30 +0100
  Re: [PATCH v1 0/6] misc: add reboot mode driver Alexandre Belloni <alexandre.belloni@free-electrons.com> - 2015-12-22 17:50 +0100
    Re: [PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-23 10:40 +0100
      Re: [PATCH v1 0/6] misc: add reboot mode driver Arnd Bergmann <arnd@arndb.de> - 2015-12-28 16:40 +0100
        Re: [PATCH v1 0/6] misc: add reboot mode driver Heiko Stübner <heiko@sntech.de> - 2015-12-28 17:00 +0100
          Re: [PATCH v1 0/6] misc: add reboot mode driver Arnd Bergmann <arnd@arndb.de> - 2015-12-28 17:20 +0100
        Re: [PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-29 09:00 +0100

csiph-web