Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1298906

Re: [PATCH v1 0/6] misc: add reboot mode driver

From Andy Yan <andy.yan@rock-chips.com>
Newsgroups linux.kernel
Subject Re: [PATCH v1 0/6] misc: add reboot mode driver
Date 2015-12-29 09:00 +0100
Message-ID <qKXmi-5Q6-3@gated-at.bofh.it> (permalink)
References <qIr7c-1XX-11@gated-at.bofh.it> <qIyil-6oh-5@gated-at.bofh.it> <qIO3L-7QT-3@gated-at.bofh.it> <qKI3U-402-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Arnd:

On 2015年12月28日 23:28, Arnd Bergmann wrote:
> On Wednesday 23 December 2015 17:31:45 Andy Yan wrote:
>>      I also have the idea to put is in drivers/power/reset,  But considering
>>      this driver have not bind anything about power, so I put it in
>> driver/misc
>>      at last. So I hope if some people can give more suggestions here.
> I vote for drivers/power/reset as well. On some platforms, the two things
> are related, on others they are not, but it's good to have it all in one
> place I think.
     Okay, I will move to drivers/power/reset next version.
>>>>    drivers/soc/rockchip/Kconfig                       |  9 ++
>>>>    drivers/soc/rockchip/Makefile                      |  1 +
>>>>    drivers/soc/rockchip/reboot.c                     | 68 +++++++++++++++
>>> And maybe that part could be made generic instead of rockchip specific.
>>> It simply uses a regmap to do the accesses, I guess a lot of other
>>> platforms will do that. We have syscon-reboot and syscon-poweroff for example.
>>>
>>> I think then we can extend the "framework" by having generic drivers to
>>> store the value in eeprom or nvram for example.
>>>
>>      I also hope the write interface can be generic. But I found some
>> platform
>>      use different hardware to store the value. For example, John's patch
>> use
>>      SRAM on qcom apq8064 to store value for nexus7. It seems there also have
>>      some platform use dram or nvram to store it. And these different
>> hardware use
>>      different write method. I don't have a generic way to handle this.
>>
>>      I have a idea to handle it like this:
>>
>> +static const struct of_device_id reboot_mode_dt_match[] = {
>> +        { .compatible = "linux,reboot-mode-sfr",    /*for magic value
>> stored in special function register, which  can be accessed by regmap*/
>> +                .data = (void *)&reboot-mode-sfr },
> I'd make this one syscon-reboot-mode, to go along with syscon-poweroff
> as implemented by drivers/power/reset/syscon-poweroff.c. The syscon concept
> is already generic enough that we don't need a linux prefix for that.
     Okay, syscon is better.
>> +        { .compatible = "linux,reboot-mode-sram",  /*for magic value
>> stored in
>> +                .data = (void *)&reboot-mode-sram },
> the sram mode should probably follow the generic SRAM binding and make
> the location that stores the reboot mode a separate partition, unless
> we want to store other data in the same partition, in which case we might
> want to use the same implementation as for the nvram.
>
>> +        { .compatible = "linux,reboot-mode-sdram",
>> +                .data = (void *)&reboot-mode-sdram }, /*for magic value
>> stored
> I think "sdram" is not an appropriate name here, as the main system memory
> might use some other technology, e.g. DRAM or DDR2-SDRAM.
>
>> +        { .compatible = "rockchip,reboot-mode-nvram",
>> +                .data = (void *)&reboot-mode-nvram },
>> +        {},
>> +};
> nvram is a complex topic by itself, because there are so many ways to do it.
> I think what you are referring to here is a battery-backed memory that uses
> one or more bytes at a fixed offset to store a particular piece of information,
> as the drivers/char/nvram.c driver does. Maybe we should put the reboot mode
> into that driver then?
>
> There are other nvram drivers at various places in the kernel, and each may
> be slightly different, or completely different, like the EFIVARs driver on
> UEFI firmware or the key/value store on Open Firmware, these probably need
> their own methods and not share the generic driver.
>
>>      the data point to different hardware access method.
>>
>>     Hope to see more suggestions from you.
> It's probably best to leave these four examples as separate drivers and we can
> add further ones when needed.
>
> 	Arnd
>
>
     Okay, thanks for your suggestion.  I will add the reboot-mode.c as 
the core library, syscon-reboot-mode.c as one example first. As for 
sram/dram/nvram case, I am not familiar with them, so hope there are 
some hero will extend them when needed.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:10 +0100
  [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:10 +0100
    Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode  driver Rob Herring <robh@kernel.org> - 2015-12-23 01:40 +0100
      Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver Moritz Fischer <moritz.fischer@ettus.com> - 2015-12-23 09:40 +0100
      Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode  driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-23 10:10 +0100
  [PATCH v1 4/6] soc: rockchip: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 3/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 5/6] ARM: dts: rockchip: add reboot-mode node Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
    Re: [PATCH v1 5/6] ARM: dts: rockchip: add reboot-mode node Heiko Stübner <heiko@sntech.de> - 2015-12-22 12:30 +0100
  [PATCH v1 2/6] dt-bindings: soc: add document for rockchip reboot-mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:20 +0100
  [PATCH v1 6/6] ARM64: dts: rockchip: add reboot-mode node Andy Yan <andy.yan@rock-chips.com> - 2015-12-22 10:30 +0100
  Re: [PATCH v1 0/6] misc: add reboot mode driver Alexandre Belloni <alexandre.belloni@free-electrons.com> - 2015-12-22 17:50 +0100
    Re: [PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-23 10:40 +0100
      Re: [PATCH v1 0/6] misc: add reboot mode driver Arnd Bergmann <arnd@arndb.de> - 2015-12-28 16:40 +0100
        Re: [PATCH v1 0/6] misc: add reboot mode driver Heiko Stübner <heiko@sntech.de> - 2015-12-28 17:00 +0100
          Re: [PATCH v1 0/6] misc: add reboot mode driver Arnd Bergmann <arnd@arndb.de> - 2015-12-28 17:20 +0100
        Re: [PATCH v1 0/6] misc: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2015-12-29 09:00 +0100

csiph-web