Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1214197

Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition

From Toshi Kani <toshi.kani@hp.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition
Date 2015-08-26 23:20 +0200
Message-ID <q1QgW-GC-7@gated-at.bofh.it> (permalink)
References <q1LKh-2zS-17@gated-at.bofh.it> <q1LTZ-2LN-39@gated-at.bofh.it> <q1MwH-3Km-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, 2015-08-26 at 10:16 -0700, Dan Williams wrote:
> On Wed, Aug 26, 2015 at 9:20 AM, Toshi Kani <toshi.kani@hp.com> wrote:
> > ACPI 6.0 NFIT Memory Device State Flags in Table 5-129 defines
> > bit 3 as follows.
> > 
> >   Bit [3] set to 1 to indicate that the Memory Device is observed
> >   to be not armed prior to OSPM hand off. A Memory Device is
> >   considered armed if it is able to accept persistent writes.
> > 
> > This bit is currently defined as ACPI_NFIT_MEM_ARMED, which can be
> > confusing as if the Memory Device is armed when this bit is set.
> > 
> > Change the name to ACPI_NFIT_MEM_NOT_ARMED per the spec.
> > 
> > Signed-off-by: Toshi Kani <toshi.kani@hp.com>
> > Cc: Dan Williams <dan.j.williams@intel.com>
> > Cc: Bob Moore <robert.moore@intel.com>
> > Cc: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > ---
> >  drivers/acpi/nfit.c              |    6 +++---
> >  drivers/acpi/nfit.h              |    2 +-
> >  include/acpi/actbl1.h            |    2 +-
> 
> This file "include/acpi/actbl1.h" is owned by the ACPICA project so
> any changes need to come through them.  But that said, I'm not sure we
> need friendly names at this level.

I think the name is misleading, but I agree with the process and this patch2
can be dropped.  It'd be nice if the ACPICA project can pick it up later
when they have a chance, though.

> What I usually say about sysfs name changes to be more human friendly
> is "sysfs is not a UI", i.e. it's not necessarily meant to be user
> friendly.  As long as the names for the flags are distinct then
> wrapping descriptive / accurate names around them is the role of
> libndctl and userspace management software.
> 
> Similar feedback for patch1 in the sense that I don't think we need to
> update the sysfs naming.  For example the API to retrieve the state of
> the "arm" flag in libndctl is ndctl_dimm_failed_arm().

I agree that we do not want to change sysfs API for friendliness, and I
understand that libndctl already consumes the strings...  But I think they
can be confusing for the long run, i.e. the flags is likely extended for
additional info, and more people may be looking at sysfs for the state. 
 It'd be a lot harder to change them later.

Thanks,
-Toshi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/2]: acpi, nfit: Clarify memory device state flags Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:30 +0200
  [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:40 +0200
    Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Ross Zwisler <ross.zwisler@linux.intel.com> - 2015-08-27 05:10 +0200
      Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-27 16:30 +0200
    Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Dan Williams <dan.j.williams@intel.com> - 2015-08-27 21:00 +0200
      Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-27 21:10 +0200
  [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:40 +0200
    Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-26 19:20 +0200
      Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-26 22:00 +0200
      Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 23:20 +0200
        Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-26 23:40 +0200
          Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 23:50 +0200
            Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 00:10 +0200
              Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 16:50 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 17:40 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 18:00 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 18:40 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 19:10 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 19:10 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 17:40 +0200
        Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition "Rafael J. Wysocki" <rafael@kernel.org> - 2015-08-27 01:20 +0200
          Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 01:40 +0200
            Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 01:40 +0200
              RE: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition "Moore, Robert" <robert.moore@intel.com> - 2015-08-27 04:00 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 16:40 +0200

csiph-web