Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1214242

Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition

From Toshi Kani <toshi.kani@hp.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition
Date 2015-08-27 01:40 +0200
Message-ID <q1Ssp-3Ko-9@gated-at.bofh.it> (permalink)
References <q1LKh-2zS-17@gated-at.bofh.it> <q1LTZ-2LN-39@gated-at.bofh.it> <q1MwH-3Km-25@gated-at.bofh.it> <q1QgW-GC-7@gated-at.bofh.it> <q1S94-3nY-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, 2015-08-27 at 01:16 +0200, Rafael J. Wysocki wrote:
> On Wed, Aug 26, 2015 at 11:12 PM, Toshi Kani <toshi.kani@hp.com> wrote:
> > On Wed, 2015-08-26 at 10:16 -0700, Dan Williams wrote:
> > > On Wed, Aug 26, 2015 at 9:20 AM, Toshi Kani <toshi.kani@hp.com> wrote:
> > > > ACPI 6.0 NFIT Memory Device State Flags in Table 5-129 defines
> > > > bit 3 as follows.
> > > > 
> > > >   Bit [3] set to 1 to indicate that the Memory Device is observed
> > > >   to be not armed prior to OSPM hand off. A Memory Device is
> > > >   considered armed if it is able to accept persistent writes.
> > > > 
> > > > This bit is currently defined as ACPI_NFIT_MEM_ARMED, which can be
> > > > confusing as if the Memory Device is armed when this bit is set.
> > > > 
> > > > Change the name to ACPI_NFIT_MEM_NOT_ARMED per the spec.
> > > > 
> > > > Signed-off-by: Toshi Kani <toshi.kani@hp.com>
> > > > Cc: Dan Williams <dan.j.williams@intel.com>
> > > > Cc: Bob Moore <robert.moore@intel.com>
> > > > Cc: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > > > ---
> > > >  drivers/acpi/nfit.c              |    6 +++---
> > > >  drivers/acpi/nfit.h              |    2 +-
> > > >  include/acpi/actbl1.h            |    2 +-
> > > 
> > > This file "include/acpi/actbl1.h" is owned by the ACPICA project so
> > > any changes need to come through them.  But that said, I'm not sure we
> > > need friendly names at this level.
> > 
> > I think the name is misleading, but I agree with the process and this 
> > patch2 can be dropped.  It'd be nice if the ACPICA project can pick it 
> > up later when they have a chance, though.
> 
> A good way to cause that to happen would be to send a patch to the
> ACPICA development list + maintainers as per MAINTAINERS.

Oh, I see.  I did run get_maintainer.pl for this patch, but devel@acpica.org
 did not come out in output...  So, I did not realize this email list.

Thanks for the suggestion!
-Toshi

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/2]: acpi, nfit: Clarify memory device state flags Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:30 +0200
  [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:40 +0200
    Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Ross Zwisler <ross.zwisler@linux.intel.com> - 2015-08-27 05:10 +0200
      Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-27 16:30 +0200
    Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Dan Williams <dan.j.williams@intel.com> - 2015-08-27 21:00 +0200
      Re: [PATCH 1/2]: nfit: Clarify memory device state flags strings Toshi Kani <toshi.kani@hp.com> - 2015-08-27 21:10 +0200
  [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 18:40 +0200
    Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-26 19:20 +0200
      Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-26 22:00 +0200
      Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 23:20 +0200
        Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-26 23:40 +0200
          Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-26 23:50 +0200
            Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 00:10 +0200
              Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 16:50 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 17:40 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 18:00 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 18:40 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Linda Knippers <linda.knippers@hp.com> - 2015-08-27 19:10 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 19:10 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-27 17:40 +0200
        Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition "Rafael J. Wysocki" <rafael@kernel.org> - 2015-08-27 01:20 +0200
          Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 01:40 +0200
            Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 01:40 +0200
              RE: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition "Moore, Robert" <robert.moore@intel.com> - 2015-08-27 04:00 +0200
                Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-27 16:40 +0200

csiph-web