Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1201735

Re: [PATCH 4/6] dm: refactor ioctl handling

From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject Re: [PATCH 4/6] dm: refactor ioctl handling
Date 2015-08-06 15:50 +0200
Message-ID <pUtIu-271-19@gated-at.bofh.it> (permalink)
References <pTEFX-3t9-1@gated-at.bofh.it> <pTEFX-3t9-3@gated-at.bofh.it> <pTOFk-SZ-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Aug 04, 2015 at 01:56:16PM -0400, Mike Snitzer wrote:
> This should be renamed to dm_prepare_ioctl_fn and the targets' hook
> would be .prepare_ioctl
> 
> Open to other names but if the targets no longer issue the ioctl there
> is little point to call it .ioctl

Sure.  I had ioctl_allowed first but that sounded so ugly that I
undid the renaming..
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 4/6] dm: refactor ioctl handling Mike Snitzer <snitzer@redhat.com> - 2015-08-04 20:00 +0200
  Re: [PATCH 4/6] dm: refactor ioctl handling Christoph Hellwig <hch@lst.de> - 2015-08-06 15:50 +0200

csiph-web