Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1200190 > unrolled thread

Re: [PATCH 4/6] dm: refactor ioctl handling

Started byMike Snitzer <snitzer@redhat.com>
First post2015-08-04 20:00 +0200
Last post2015-08-06 15:50 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 4/6] dm: refactor ioctl handling Mike Snitzer <snitzer@redhat.com> - 2015-08-04 20:00 +0200
    Re: [PATCH 4/6] dm: refactor ioctl handling Christoph Hellwig <hch@lst.de> - 2015-08-06 15:50 +0200

#1200190 — Re: [PATCH 4/6] dm: refactor ioctl handling

FromMike Snitzer <snitzer@redhat.com>
Date2015-08-04 20:00 +0200
SubjectRe: [PATCH 4/6] dm: refactor ioctl handling
Message-ID<pTOFk-SZ-11@gated-at.bofh.it>
On Tue, Aug 04 2015 at  3:11am -0400,
Christoph Hellwig <hch@lst.de> wrote:

> This moves the call to blkdev_ioctl and the argument checking to core code,
> and only leaves a callout to find the block device to operate on it the
> targets.  This will simplifies the code and will allow us to pass through
> ioctl-like command using other methods in the next patch.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
...
> diff --git a/drivers/md/dm.c b/drivers/md/dm.c
> index f331d88..c68eb91 100644
> --- a/drivers/md/dm.c
> +++ b/drivers/md/dm.c
> @@ -584,7 +584,17 @@ retry:
>  		goto out;
>  	}
>  
> -	r = tgt->type->ioctl(tgt, cmd, arg);
> +	r = tgt->type->ioctl(tgt, &bdev, &mode);
> +	if (r < 0)
> +		goto out;
> +
> +	if (r > 0) {
> +		r = scsi_verify_blk_ioctl(NULL, cmd);
> +		if (r)
> +			goto out;
> +	}
> +
> +	r =  __blkdev_driver_ioctl(bdev, mode, cmd, arg);
>  
>  out:
>  	dm_put_live_table(md, srcu_idx);
> diff --git a/include/linux/device-mapper.h b/include/linux/device-mapper.h
> index 51cc1de..9b73138 100644
> --- a/include/linux/device-mapper.h
> +++ b/include/linux/device-mapper.h
> @@ -79,8 +79,8 @@ typedef void (*dm_status_fn) (struct dm_target *ti, status_type_t status_type,
>  
>  typedef int (*dm_message_fn) (struct dm_target *ti, unsigned argc, char **argv);
>  
> -typedef int (*dm_ioctl_fn) (struct dm_target *ti, unsigned int cmd,
> -			    unsigned long arg);
> +typedef int (*dm_ioctl_fn) (struct dm_target *ti,
> +			    struct block_device **bdev, fmode_t *mode);
>  
>  typedef int (*dm_merge_fn) (struct dm_target *ti, struct bvec_merge_data *bvm,
>  			    struct bio_vec *biovec, int max_size);

This should be renamed to dm_prepare_ioctl_fn and the targets' hook
would be .prepare_ioctl

Open to other names but if the targets no longer issue the ioctl there
is little point to call it .ioctl
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1201735

FromChristoph Hellwig <hch@lst.de>
Date2015-08-06 15:50 +0200
Message-ID<pUtIu-271-19@gated-at.bofh.it>
In reply to#1200190
On Tue, Aug 04, 2015 at 01:56:16PM -0400, Mike Snitzer wrote:
> This should be renamed to dm_prepare_ioctl_fn and the targets' hook
> would be .prepare_ioctl
> 
> Open to other names but if the targets no longer issue the ioctl there
> is little point to call it .ioctl

Sure.  I had ioctl_allowed first but that sounded so ugly that I
undid the renaming..
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web