Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742209 > unrolled thread

Re: [PATCH] x86: use register variable to get stack pointer value

Started byJosh Poimboeuf <jpoimboe@redhat.com>
First post2017-09-29 17:40 +0200
Last post2017-09-29 21:20 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH] x86: use register variable to get stack pointer value Josh Poimboeuf <jpoimboe@redhat.com> - 2017-09-29 17:40 +0200
    Re: [PATCH] x86: use register variable to get stack pointer value Andy Lutomirski <luto@kernel.org> - 2017-09-29 20:40 +0200
      Re: [PATCH] x86: use register variable to get stack pointer value Josh Poimboeuf <jpoimboe@redhat.com> - 2017-09-29 21:20 +0200

#1742209 — Re: [PATCH] x86: use register variable to get stack pointer value

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2017-09-29 17:40 +0200
SubjectRe: [PATCH] x86: use register variable to get stack pointer value
Message-ID<uv5yr-7ZA-25@gated-at.bofh.it>
On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
> Currently we use current_stack_pointer() function to get the value
> of the stack pointer register. Since commit f5caf621ee35
> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
> register variable declared. It can be used instead of current_stack_pointer()
> function which allows to optimize away some excessive "mov %rsp, %<dst>"
> instructions:
> 
> -mov    %rsp,%rdx
> -sub    %rdx,%rax
> -cmp    $0x3fff,%rax
> -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>
> 
> +sub    %rsp,%rax
> +cmp    $0x3fff,%rax
> +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>
> 
> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
> and use it instead of removed function.
> 
> Signed-off-by: Andrey Ryabinin <aryabinin@virtuozzo.com>

Reviewed-by: Josh Poimboeuf <jpoimboe@redhat.com>

-- 
Josh

[toc] | [next] | [standalone]


#1742270

FromAndy Lutomirski <luto@kernel.org>
Date2017-09-29 20:40 +0200
Message-ID<uv8mB-1nQ-1@gated-at.bofh.it>
In reply to#1742209
On Fri, Sep 29, 2017 at 8:38 AM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
>> Currently we use current_stack_pointer() function to get the value
>> of the stack pointer register. Since commit f5caf621ee35
>> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
>> register variable declared. It can be used instead of current_stack_pointer()
>> function which allows to optimize away some excessive "mov %rsp, %<dst>"
>> instructions:
>>
>> -mov    %rsp,%rdx
>> -sub    %rdx,%rax
>> -cmp    $0x3fff,%rax
>> -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>
>>
>> +sub    %rsp,%rax
>> +cmp    $0x3fff,%rax
>> +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>
>>
>> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
>> and use it instead of removed function.
>>
>> Signed-off-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
>
> Reviewed-by: Josh Poimboeuf <jpoimboe@redhat.com>


Ok with me.  As an alternative, you could leave it as
current_stack_pointer(), but either way is fine.

[toc] | [prev] | [next] | [standalone]


#1742294

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2017-09-29 21:20 +0200
Message-ID<uv8Zj-1R9-1@gated-at.bofh.it>
In reply to#1742270
On Fri, Sep 29, 2017 at 11:37:52AM -0700, Andy Lutomirski wrote:
> On Fri, Sep 29, 2017 at 8:38 AM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
> >> Currently we use current_stack_pointer() function to get the value
> >> of the stack pointer register. Since commit f5caf621ee35
> >> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
> >> register variable declared. It can be used instead of current_stack_pointer()
> >> function which allows to optimize away some excessive "mov %rsp, %<dst>"
> >> instructions:
> >>
> >> -mov    %rsp,%rdx
> >> -sub    %rdx,%rax
> >> -cmp    $0x3fff,%rax
> >> -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>
> >>
> >> +sub    %rsp,%rax
> >> +cmp    $0x3fff,%rax
> >> +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>
> >>
> >> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
> >> and use it instead of removed function.
> >>
> >> Signed-off-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
> >
> > Reviewed-by: Josh Poimboeuf <jpoimboe@redhat.com>
> 
> 
> Ok with me.  As an alternative, you could leave it as
> current_stack_pointer(), but either way is fine.

Good point, I think changing current_stack_pointer() to return the
global variable would be cleaner.

-- 
Josh

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web