Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742270

Re: [PATCH] x86: use register variable to get stack pointer value

From Andy Lutomirski <luto@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH] x86: use register variable to get stack pointer value
Date 2017-09-29 20:40 +0200
Message-ID <uv8mB-1nQ-1@gated-at.bofh.it> (permalink)
References <uv5yr-7ZA-27@gated-at.bofh.it> <uv5yr-7ZA-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Sep 29, 2017 at 8:38 AM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
>> Currently we use current_stack_pointer() function to get the value
>> of the stack pointer register. Since commit f5caf621ee35
>> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
>> register variable declared. It can be used instead of current_stack_pointer()
>> function which allows to optimize away some excessive "mov %rsp, %<dst>"
>> instructions:
>>
>> -mov    %rsp,%rdx
>> -sub    %rdx,%rax
>> -cmp    $0x3fff,%rax
>> -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>
>>
>> +sub    %rsp,%rax
>> +cmp    $0x3fff,%rax
>> +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>
>>
>> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
>> and use it instead of removed function.
>>
>> Signed-off-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
>
> Reviewed-by: Josh Poimboeuf <jpoimboe@redhat.com>


Ok with me.  As an alternative, you could leave it as
current_stack_pointer(), but either way is fine.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH] x86: use register variable to get stack pointer value Josh Poimboeuf <jpoimboe@redhat.com> - 2017-09-29 17:40 +0200
  Re: [PATCH] x86: use register variable to get stack pointer value Andy Lutomirski <luto@kernel.org> - 2017-09-29 20:40 +0200
    Re: [PATCH] x86: use register variable to get stack pointer value Josh Poimboeuf <jpoimboe@redhat.com> - 2017-09-29 21:20 +0200

csiph-web