Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1739827 > unrolled thread
| Started by | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| First post | 2017-09-26 14:20 +0200 |
| Last post | 2017-09-28 10:10 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next, next_timer) Peter Zijlstra <peterz@infradead.org> - 2017-09-26 14:20 +0200
Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next, next_timer) Thomas Gleixner <tglx@linutronix.de> - 2017-09-28 10:10 +0200
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Date | 2017-09-26 14:20 +0200 |
| Subject | Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next, next_timer) |
| Message-ID | <utX0e-4FS-21@gated-at.bofh.it> |
On Thu, Aug 31, 2017 at 12:23:37PM -0000, Anna-Maria Gleixner wrote: > The hrtimer_cpu_base struct member expires_next and next_timer are > conditional members (CONFIG_HIGH_RES_TIMERS). This makes the hrtimer code > more complex and harder to understand than it actually is. > > Reduce the conditionals related to those two struct members. So this grows the data structure for !HIGH_RES for easier code? We no longer care about archs that don't support HIGH_RES?
[toc] | [next] | [standalone]
| From | Thomas Gleixner <tglx@linutronix.de> |
|---|---|
| Date | 2017-09-28 10:10 +0200 |
| Message-ID | <uuC3o-6tW-11@gated-at.bofh.it> |
| In reply to | #1739827 |
On Tue, 26 Sep 2017, Peter Zijlstra wrote: > On Thu, Aug 31, 2017 at 12:23:37PM -0000, Anna-Maria Gleixner wrote: > > The hrtimer_cpu_base struct member expires_next and next_timer are > > conditional members (CONFIG_HIGH_RES_TIMERS). This makes the hrtimer code > > more complex and harder to understand than it actually is. > > > > Reduce the conditionals related to those two struct members. > > So this grows the data structure for !HIGH_RES for easier code? We no > longer care about archs that don't support HIGH_RES? We care, but there is a tradeoff between the required conditional code and the marginal storage overhead. Easier to follow code which does a few superflous things for the !highres case is certainly preferred. Thanks, tglx
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web