Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1741257

Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next, next_timer)

From Thomas Gleixner <tglx@linutronix.de>
Newsgroups linux.kernel
Subject Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next, next_timer)
Date 2017-09-28 10:10 +0200
Message-ID <uuC3o-6tW-11@gated-at.bofh.it> (permalink)
References <ukwLD-5Ay-3@gated-at.bofh.it> <ukwLD-5Ay-5@gated-at.bofh.it> <utX0e-4FS-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, 26 Sep 2017, Peter Zijlstra wrote:

> On Thu, Aug 31, 2017 at 12:23:37PM -0000, Anna-Maria Gleixner wrote:
> > The hrtimer_cpu_base struct member expires_next and next_timer are
> > conditional members (CONFIG_HIGH_RES_TIMERS). This makes the hrtimer code
> > more complex and harder to understand than it actually is.
> > 
> > Reduce the conditionals related to those two struct members.
> 
> So this grows the data structure for !HIGH_RES for easier code? We no
> longer care about archs that don't support HIGH_RES?

We care, but there is a tradeoff between the required conditional code and
the marginal storage overhead. Easier to follow code which does a few
superflous things for the !highres case is certainly preferred.

Thanks,

	tglx

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH 08/25] hrtimer: Reduce conditional code (expires_next,  next_timer) Thomas Gleixner <tglx@linutronix.de> - 2017-09-28 10:10 +0200

csiph-web