Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1707449 > unrolled thread
| Started by | Matt Roper <matthew.d.roper@intel.com> |
|---|---|
| First post | 2017-08-09 18:20 +0200 |
| Last post | 2017-08-10 11:40 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Matt Roper <matthew.d.roper@intel.com> - 2017-08-09 18:20 +0200
Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Jean Delvare <jdelvare@suse.de> - 2017-08-10 11:40 +0200
| From | Matt Roper <matthew.d.roper@intel.com> |
|---|---|
| Date | 2017-08-09 18:20 +0200 |
| Subject | Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) |
| Message-ID | <ucBSa-1ep-13@gated-at.bofh.it> |
On Mon, Jul 31, 2017 at 10:36:05AM +0200, Jean Delvare wrote: > Hi Matt, Mauro, > > On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote: > > On Tue, 8 Mar 2016 10:32:37 -0800, Matt Roper wrote: > > > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for > > > decoding DMI memory device entries. Move the structure definition to > > > dmi.h so that it can be shared between those drivers and also other > > > parts of the kernel; the i915 graphics driver is going to need to use > > > this structure soon as well. As part of this move we rename the > > > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper > > > 'dmi' prefix. > > > > > > v2: > > > - Rename structure to dmi_entry_memdev. (Jean) > > > - Use __packed instead of __attribute__((__packed__)) for consistency > > > with the rest of the dmi.h header. (Jean) > > > > Looks better. (...) > > What happened to this patch? I never received v3. Is it sill needed? We ended up going a different direction in the graphics driver and wound up not needing access to this structure. If there's still interest in the general refactoring here, let me know and I can incorporate your last feedback and respin a v3. Matt > -- > Jean Delvare > SUSE L3 Support -- Matt Roper Graphics Software Engineer IoTG Platform Enabling & Development Intel Corporation (916) 356-2795
[toc] | [next] | [standalone]
| From | Jean Delvare <jdelvare@suse.de> |
|---|---|
| Date | 2017-08-10 11:40 +0200 |
| Message-ID | <ucS6B-3LT-17@gated-at.bofh.it> |
| In reply to | #1707449 |
On mer., 2017-08-09 at 09:18 -0700, Matt Roper wrote: > On Mon, Jul 31, 2017 at 10:36:05AM +0200, Jean Delvare wrote: > > > > Hi Matt, Mauro, > > > > On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote: > > > > > > On Tue, 8 Mar 2016 10:32:37 -0800, Matt Roper wrote: > > > > > > > > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for > > > > decoding DMI memory device entries. Move the structure definition to > > > > dmi.h so that it can be shared between those drivers and also other > > > > parts of the kernel; the i915 graphics driver is going to need to use > > > > this structure soon as well. As part of this move we rename the > > > > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper > > > > 'dmi' prefix. > > > > > > > > v2: > > > > - Rename structure to dmi_entry_memdev. (Jean) > > > > - Use __packed instead of __attribute__((__packed__)) for consistency > > > > with the rest of the dmi.h header. (Jean) > > > > > > Looks better. (...) > > > > What happened to this patch? I never received v3. Is it sill needed? > > We ended up going a different direction in the graphics driver and wound > up not needing access to this structure. If there's still interest in > the general refactoring here, let me know and I can incorporate your > last feedback and respin a v3. No, if you don't need it anymore I'll just drop it. Thanks, -- Jean Delvare SUSE L3 Support
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web