Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1708371

Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2)

From Jean Delvare <jdelvare@suse.de>
Newsgroups linux.kernel
Subject Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2)
Date 2017-08-10 11:40 +0200
Message-ID <ucS6B-3LT-17@gated-at.bofh.it> (permalink)
References <rap5F-Qj-47@gated-at.bofh.it> <rauI1-4Kx-3@gated-at.bofh.it> <rdGWl-8uZ-1@gated-at.bofh.it> <u9ep4-3Xg-11@gated-at.bofh.it> <ucBSa-1ep-13@gated-at.bofh.it>
Organization Suse Linux

Show all headers | View raw


On mer., 2017-08-09 at 09:18 -0700, Matt Roper wrote:
> On Mon, Jul 31, 2017 at 10:36:05AM +0200, Jean Delvare wrote:
> > 
> > Hi Matt, Mauro,
> > 
> > On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote:
> > > 
> > > On Tue,  8 Mar 2016 10:32:37 -0800, Matt Roper wrote:
> > > > 
> > > > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for
> > > > decoding DMI memory device entries.  Move the structure definition to
> > > > dmi.h so that it can be shared between those drivers and also other
> > > > parts of the kernel; the i915 graphics driver is going to need to use
> > > > this structure soon as well.  As part of this move we rename the
> > > > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper
> > > > 'dmi' prefix.
> > > > 
> > > > v2:
> > > >  - Rename structure to dmi_entry_memdev.  (Jean)
> > > >  - Use __packed instead of __attribute__((__packed__)) for consistency
> > > >    with the rest of the dmi.h header.  (Jean)  
> > > 
> > > Looks better. (...)
> > 
> > What happened to this patch? I never received v3. Is it sill needed?
> 
> We ended up going a different direction in the graphics driver and wound
> up not needing access to this structure.  If there's still interest in
> the general refactoring here, let me know and I can incorporate your
> last feedback and respin a v3.

No, if you don't need it anymore I'll just drop it.

Thanks,
-- 
Jean Delvare
SUSE L3 Support

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Matt Roper <matthew.d.roper@intel.com> - 2017-08-09 18:20 +0200
  Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Jean Delvare <jdelvare@suse.de> - 2017-08-10 11:40 +0200

csiph-web