Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1694722 > unrolled thread

[PATCH 00/14] Remove unused structure amd_pp_display_configuration

Started byRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
First post2017-07-24 15:40 +0200
Last post2017-07-24 15:40 +0200
Articles 9 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH 00/14] Remove unused structure amd_pp_display_configuration Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
    [PATCH 13/14] amdgpu: amdgpu_dpm: Remove unused field Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
    [PATCH 07/14] amdgpu: powerplay: polaris10_smc: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
    [PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
      Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 16:10 +0200
        Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-26 15:50 +0200
    [PATCH 14/14] amdgpu: powerplay: Remove unused structure Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
    [PATCH 09/14] amdgpu: powerplay: rv_hwmgr: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
    [PATCH 06/14] amdgpu: powerplay: iceland_smc: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200

#1694722 — [PATCH 00/14] Remove unused structure amd_pp_display_configuration

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 00/14] Remove unused structure amd_pp_display_configuration
Message-ID<u6LKx-5uV-5@gated-at.bofh.it>
While trying to fix the error message

amdgpu: [powerplay] min_core_set_clock not set

on my carizzo board. I Realized that the structure display_config was never
set and therefore a lot of code could be simplified.

Also due to display_config never set, the error message was invalid.

Other people referencing it:

http://www.mikejonesey.co.uk/linux/optimisation/amd-carrizo-powerplay-this-function-not-implement

Ricardo Ribalda Delgado (14):
  amdgpu: powerplay: Remove unused function
  amdgpu: powerplay: Remove unused function
  amdgpu: powerplay: cz_hwmgr: Fix invalid error message.
  amdgpu: powerplay: smu7_hwmgr: Assume display_config is zero
  amdgpu: powerplay: fiji_smc: Assume display_config is zero
  amdgpu: powerplay: iceland_smc: Assume display_config is zero
  amdgpu: powerplay: polaris10_smc: Assume display_config is zero
  amdgpu: powerplay: tonga_smc: Assume display_config is zero
  amdgpu: powerplay: rv_hwmgr: Assume display_config is zero
  amdgpu: powerplay: vega10_hwmgr: Assume display_config is zero
  amdgpu: ci_dpm: Assume pm_display_cfg is zero
  amdgpu: powerplay: hwmgr: Remove unused field
  amdgpu: amdgpu_dpm: Remove unused field
  amdgpu: powerplay: Remove unused structure

 drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h            |  1 -
 drivers/gpu/drm/amd/amdgpu/ci_dpm.c                |  6 ---
 drivers/gpu/drm/amd/powerplay/amd_powerplay.c      | 21 -----------
 .../gpu/drm/amd/powerplay/eventmgr/eventtasks.c    |  1 -
 drivers/gpu/drm/amd/powerplay/hwmgr/cz_hwmgr.c     | 20 +++-------
 .../gpu/drm/amd/powerplay/hwmgr/hardwaremanager.c  | 25 -------------
 drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c     |  2 -
 drivers/gpu/drm/amd/powerplay/hwmgr/smu7_hwmgr.c   | 10 ++---
 drivers/gpu/drm/amd/powerplay/hwmgr/vega10_hwmgr.c | 18 +++------
 drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h  | 43 ----------------------
 .../gpu/drm/amd/powerplay/inc/hardwaremanager.h    |  3 --
 drivers/gpu/drm/amd/powerplay/inc/hwmgr.h          |  1 -
 drivers/gpu/drm/amd/powerplay/smumgr/fiji_smc.c    |  5 +--
 drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c |  3 +-
 .../gpu/drm/amd/powerplay/smumgr/polaris10_smc.c   |  5 +--
 drivers/gpu/drm/amd/powerplay/smumgr/tonga_smc.c   |  3 +-
 16 files changed, 20 insertions(+), 147 deletions(-)

-- 
2.13.2

[toc] | [next] | [standalone]


#1694723 — [PATCH 13/14] amdgpu: amdgpu_dpm: Remove unused field

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 13/14] amdgpu: amdgpu_dpm: Remove unused field
Message-ID<u6LKz-5uV-33@gated-at.bofh.it>
In reply to#1694722
Remove unused field pm_display_cfg

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h b/drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h
index 8c96a4caa715..5c740814dba4 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h
@@ -488,7 +488,6 @@ struct amdgpu_pm {
 	const struct amdgpu_dpm_funcs *funcs;
 	uint32_t                pcie_gen_mask;
 	uint32_t                pcie_mlw_mask;
-	struct amd_pp_display_configuration pm_display_cfg;/* set by DAL */
 };
 
 #define R600_SSTU_DFLT                               0
-- 
2.13.2

[toc] | [prev] | [next] | [standalone]


#1694725 — [PATCH 07/14] amdgpu: powerplay: polaris10_smc: Assume display_config is zero

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 07/14] amdgpu: powerplay: polaris10_smc: Assume display_config is zero
Message-ID<u6LKz-5uV-39@gated-at.bofh.it>
In reply to#1694722
display_config is never set, we can assume it is zero.

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/powerplay/smumgr/polaris10_smc.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/polaris10_smc.c b/drivers/gpu/drm/amd/powerplay/smumgr/polaris10_smc.c
index f68e759e8be2..c889fc930cfc 100644
--- a/drivers/gpu/drm/amd/powerplay/smumgr/polaris10_smc.c
+++ b/drivers/gpu/drm/amd/powerplay/smumgr/polaris10_smc.c
@@ -711,11 +711,12 @@ static int polaris10_populate_single_graphic_level(struct pp_hwmgr *hwmgr,
 	level->DownHyst = 0;
 	level->VoltageDownHyst = 0;
 	level->PowerThrottle = 0;
-	data->display_timing.min_clock_in_sr = hwmgr->display_config.min_core_set_clock_in_sr;
+	data->display_timing.min_clock_in_sr = 0;
 
-	if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_SclkDeepSleep))
-		level->DeepSleepDivId = smu7_get_sleep_divider_id_from_clock(clock,
-								hwmgr->display_config.min_core_set_clock_in_sr);
+	if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps,
+			    PHM_PlatformCaps_SclkDeepSleep))
+		level->DeepSleepDivId =
+			smu7_get_sleep_divider_id_from_clock(clock, 0);
 
 	/* Default to slow, highest DPM level will be
 	 * set to PPSMC_DISPLAY_WATERMARK_LOW later.
-- 
2.13.2

[toc] | [prev] | [next] | [standalone]


#1694726 — [PATCH 01/14] amdgpu: powerplay: Remove unused function

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 01/14] amdgpu: powerplay: Remove unused function
Message-ID<u6LKz-5uV-41@gated-at.bofh.it>
In reply to#1694722
amd_powerplay_display_configuration_change is never called.

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/powerplay/amd_powerplay.c     | 21 ---------------------
 drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h |  3 ---
 2 files changed, 24 deletions(-)

diff --git a/drivers/gpu/drm/amd/powerplay/amd_powerplay.c b/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
index f73e80c4bf33..1ee7aa5546bf 100644
--- a/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
+++ b/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
@@ -1237,27 +1237,6 @@ int amd_powerplay_reset(void *handle)
 	return pem_handle_event(eventmgr, AMD_PP_EVENT_COMPLETE_INIT, &event_data);
 }
 
-/* export this function to DAL */
-
-int amd_powerplay_display_configuration_change(void *handle,
-	const struct amd_pp_display_configuration *display_config)
-{
-	struct pp_hwmgr  *hwmgr;
-	struct pp_instance *pp_handle = (struct pp_instance *)handle;
-	int ret = 0;
-
-	ret = pp_check(pp_handle);
-
-	if (ret != 0)
-		return ret;
-
-	hwmgr = pp_handle->hwmgr;
-	mutex_lock(&pp_handle->pp_lock);
-	phm_store_dal_configuration_data(hwmgr, display_config);
-	mutex_unlock(&pp_handle->pp_lock);
-	return 0;
-}
-
 int amd_powerplay_get_display_power_level(void *handle,
 		struct amd_pp_simple_clock_info *output)
 {
diff --git a/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h b/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
index 07e9c0b5915d..ae49af5cc5d1 100644
--- a/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
+++ b/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
@@ -407,9 +407,6 @@ int amd_powerplay_destroy(void *handle);
 
 int amd_powerplay_reset(void *handle);
 
-int amd_powerplay_display_configuration_change(void *handle,
-		const struct amd_pp_display_configuration *input);
-
 int amd_powerplay_get_display_power_level(void *handle,
 		struct amd_pp_simple_clock_info *output);
 
-- 
2.13.2

[toc] | [prev] | [next] | [standalone]


#1694751 — Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 16:10 +0200
SubjectRe: [PATCH 01/14] amdgpu: powerplay: Remove unused function
Message-ID<u6MdA-5Wc-17@gated-at.bofh.it>
In reply to#1694726
Hi Harry
On Mon, Jul 24, 2017 at 4:01 PM, Harry Wentland <harry.wentland@amd.com> wrote:

>
> This is used and needed by the DC display driver. See
> display/amdgpu_dm/amdgpu_dm_services.c:193 in Alex's amd-staging-4.11 tree:
>
> https://cgit.freedesktop.org/~agd5f/linux/tree/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_services.c?h=amd-staging-4.11
>

I could not find any reference to the function in linux-next (>4.12)

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/gpu/drm/amd

Is there any plan to merge Alex's amd-stagin tree?

Sorry, I am not very familiar with this subsystem.

Regards!

[toc] | [prev] | [next] | [standalone]


#1697115 — Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-26 15:50 +0200
SubjectRe: [PATCH 01/14] amdgpu: powerplay: Remove unused function
Message-ID<u7uRl-Xi-25@gated-at.bofh.it>
In reply to#1694751
Hi Harry

On Mon, Jul 24, 2017 at 5:45 PM, Harry Wentland <harry.wentland@amd.com> wrote:
> On 2017-07-24 10:06 AM, Ricardo Ribalda Delgado wrote:
>> Hi Harry
>> On Mon, Jul 24, 2017 at 4:01 PM, Harry Wentland <harry.wentland@amd.com> wrote:
>>
>>>
>>> This is used and needed by the DC display driver. See
>>> display/amdgpu_dm/amdgpu_dm_services.c:193 in Alex's amd-staging-4.11 tree:
>>>
>>> https://cgit.freedesktop.org/~agd5f/linux/tree/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_services.c?h=amd-staging-4.11
>>>
>>
>> I could not find any reference to the function in linux-next (>4.12)
>>
>> https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/gpu/drm/amd
>>
>> Is there any plan to merge Alex's amd-stagin tree?
>
> The plan is to merge/upstream the amd/display portion of Alex's
> amd-staging tree. We're currently working on the community feedback we
> received to get it into shape.

Is there any timeframe for this?

 At least we should remove the   pr_info("min_core_set_clock not
set\n"); message.

it is (very) misleading right now.

Regards!

>
> Harry
>
>>
>> Sorry, I am not very familiar with this subsystem.
>>
>> Regards!
>>



-- 
Ricardo Ribalda

[toc] | [prev] | [next] | [standalone]


#1694728 — [PATCH 14/14] amdgpu: powerplay: Remove unused structure

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 14/14] amdgpu: powerplay: Remove unused structure
Message-ID<u6LKz-5uV-47@gated-at.bofh.it>
In reply to#1694722
Remove unused structure definition amd_pp_display_configuration.

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h | 40 -----------------------
 1 file changed, 40 deletions(-)

diff --git a/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h b/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
index ae49af5cc5d1..6b6f2f7c8527 100644
--- a/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
+++ b/drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h
@@ -191,46 +191,6 @@ struct single_display_configuration
 
 #define MAX_NUM_DISPLAY 32
 
-struct amd_pp_display_configuration {
-	bool nb_pstate_switch_disable;/* controls NB PState switch */
-	bool cpu_cc6_disable; /* controls CPU CState switch ( on or off) */
-	bool cpu_pstate_disable;
-	uint32_t cpu_pstate_separation_time;
-
-	uint32_t num_display;  /* total number of display*/
-	uint32_t num_path_including_non_display;
-	uint32_t crossfire_display_index;
-	uint32_t min_mem_set_clock;
-	uint32_t min_core_set_clock;
-	/* unit 10KHz x bit*/
-	uint32_t min_bus_bandwidth;
-	/* minimum required stutter sclk, in 10khz uint32_t ulMinCoreSetClk;*/
-	uint32_t min_core_set_clock_in_sr;
-
-	struct single_display_configuration displays[MAX_NUM_DISPLAY];
-
-	uint32_t vrefresh; /* for active display*/
-
-	uint32_t min_vblank_time; /* for active display*/
-	bool multi_monitor_in_sync;
-	/* Controller Index of primary display - used in MCLK SMC switching hang
-	 * SW Workaround*/
-	uint32_t crtc_index;
-	/* htotal*1000/pixelclk - used in MCLK SMC switching hang SW Workaround*/
-	uint32_t line_time_in_us;
-	bool invalid_vblank_time;
-
-	uint32_t display_clk;
-	/*
-	 * for given display configuration if multimonitormnsync == false then
-	 * Memory clock DPMS with this latency or below is allowed, DPMS with
-	 * higher latency not allowed.
-	 */
-	uint32_t dce_tolerable_mclk_in_active_latency;
-	uint32_t min_dcef_set_clk;
-	uint32_t min_dcef_deep_sleep_set_clk;
-};
-
 struct amd_pp_simple_clock_info {
 	uint32_t	engine_max_clock;
 	uint32_t	memory_max_clock;
-- 
2.13.2

[toc] | [prev] | [next] | [standalone]


#1694731 — [PATCH 09/14] amdgpu: powerplay: rv_hwmgr: Assume display_config is zero

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 09/14] amdgpu: powerplay: rv_hwmgr: Assume display_config is zero
Message-ID<u6LKz-5uV-53@gated-at.bofh.it>
In reply to#1694722
display_config is never set, so we can assume that it is zero.

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c b/drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c
index 4c7f430b36eb..64a3cb66a3a0 100644
--- a/drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c
+++ b/drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c
@@ -241,8 +241,6 @@ static int rv_tf_set_clock_limit(struct pp_hwmgr *hwmgr, void *input,
 	struct PP_Clocks clocks = {0};
 	struct pp_display_clock_request clock_req;
 
-	clocks.dcefClock = hwmgr->display_config.min_dcef_set_clk;
-	clocks.dcefClockInSR = hwmgr->display_config.min_dcef_deep_sleep_set_clk;
 	clock_req.clock_type = amd_pp_dcf_clock;
 	clock_req.clock_freq_in_khz = clocks.dcefClock * 10;
 
-- 
2.13.2

[toc] | [prev] | [next] | [standalone]


#1694732 — [PATCH 06/14] amdgpu: powerplay: iceland_smc: Assume display_config is zero

FromRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Date2017-07-24 15:40 +0200
Subject[PATCH 06/14] amdgpu: powerplay: iceland_smc: Assume display_config is zero
Message-ID<u6LKz-5uV-51@gated-at.bofh.it>
In reply to#1694722
display_config is never set, we can assume it is zero.

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c b/drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c
index 51adf04ab4b3..dce87fc13e0c 100644
--- a/drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c
+++ b/drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c
@@ -780,8 +780,7 @@ static int iceland_populate_single_graphic_level(struct pp_hwmgr *hwmgr,
 	graphic_level->VoltageDownHyst = 0;
 	graphic_level->PowerThrottle = 0;
 
-	data->display_timing.min_clock_in_sr =
-			hwmgr->display_config.min_core_set_clock_in_sr;
+	data->display_timing.min_clock_in_sr = 0;
 
 	if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps,
 			PHM_PlatformCaps_SclkDeepSleep))
-- 
2.13.2

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web