Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1694722
| From | Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/14] Remove unused structure amd_pp_display_configuration |
| Date | 2017-07-24 15:40 +0200 |
| Message-ID | <u6LKx-5uV-5@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
While trying to fix the error message amdgpu: [powerplay] min_core_set_clock not set on my carizzo board. I Realized that the structure display_config was never set and therefore a lot of code could be simplified. Also due to display_config never set, the error message was invalid. Other people referencing it: http://www.mikejonesey.co.uk/linux/optimisation/amd-carrizo-powerplay-this-function-not-implement Ricardo Ribalda Delgado (14): amdgpu: powerplay: Remove unused function amdgpu: powerplay: Remove unused function amdgpu: powerplay: cz_hwmgr: Fix invalid error message. amdgpu: powerplay: smu7_hwmgr: Assume display_config is zero amdgpu: powerplay: fiji_smc: Assume display_config is zero amdgpu: powerplay: iceland_smc: Assume display_config is zero amdgpu: powerplay: polaris10_smc: Assume display_config is zero amdgpu: powerplay: tonga_smc: Assume display_config is zero amdgpu: powerplay: rv_hwmgr: Assume display_config is zero amdgpu: powerplay: vega10_hwmgr: Assume display_config is zero amdgpu: ci_dpm: Assume pm_display_cfg is zero amdgpu: powerplay: hwmgr: Remove unused field amdgpu: amdgpu_dpm: Remove unused field amdgpu: powerplay: Remove unused structure drivers/gpu/drm/amd/amdgpu/amdgpu_dpm.h | 1 - drivers/gpu/drm/amd/amdgpu/ci_dpm.c | 6 --- drivers/gpu/drm/amd/powerplay/amd_powerplay.c | 21 ----------- .../gpu/drm/amd/powerplay/eventmgr/eventtasks.c | 1 - drivers/gpu/drm/amd/powerplay/hwmgr/cz_hwmgr.c | 20 +++------- .../gpu/drm/amd/powerplay/hwmgr/hardwaremanager.c | 25 ------------- drivers/gpu/drm/amd/powerplay/hwmgr/rv_hwmgr.c | 2 - drivers/gpu/drm/amd/powerplay/hwmgr/smu7_hwmgr.c | 10 ++--- drivers/gpu/drm/amd/powerplay/hwmgr/vega10_hwmgr.c | 18 +++------ drivers/gpu/drm/amd/powerplay/inc/amd_powerplay.h | 43 ---------------------- .../gpu/drm/amd/powerplay/inc/hardwaremanager.h | 3 -- drivers/gpu/drm/amd/powerplay/inc/hwmgr.h | 1 - drivers/gpu/drm/amd/powerplay/smumgr/fiji_smc.c | 5 +-- drivers/gpu/drm/amd/powerplay/smumgr/iceland_smc.c | 3 +- .../gpu/drm/amd/powerplay/smumgr/polaris10_smc.c | 5 +-- drivers/gpu/drm/amd/powerplay/smumgr/tonga_smc.c | 3 +- 16 files changed, 20 insertions(+), 147 deletions(-) -- 2.13.2
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/14] Remove unused structure amd_pp_display_configuration Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
[PATCH 13/14] amdgpu: amdgpu_dpm: Remove unused field Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
[PATCH 07/14] amdgpu: powerplay: polaris10_smc: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
[PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 16:10 +0200
Re: [PATCH 01/14] amdgpu: powerplay: Remove unused function Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-26 15:50 +0200
[PATCH 14/14] amdgpu: powerplay: Remove unused structure Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
[PATCH 09/14] amdgpu: powerplay: rv_hwmgr: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
[PATCH 06/14] amdgpu: powerplay: iceland_smc: Assume display_config is zero Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2017-07-24 15:40 +0200
csiph-web