Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1696751 > unrolled thread

Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure

Started byJonathan Neuschäfer <j.neuschaefer@gmx.net>
First post2017-07-26 05:10 +0200
Last post2017-07-26 20:50 +0200
Articles 4 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Jonathan Neuschäfer <j.neuschaefer@gmx.net> - 2017-07-26 05:10 +0200
    Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Palmer Dabbelt <palmer@dabbelt.com> - 2017-07-26 07:30 +0200
      Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Arnd Bergmann <arnd@arndb.de> - 2017-07-26 09:00 +0200
      Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Jonathan Neuschäfer <j.neuschaefer@gmx.net> - 2017-07-26 20:50 +0200

#1696751 — Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure

FromJonathan Neuschäfer <j.neuschaefer@gmx.net>
Date2017-07-26 05:10 +0200
SubjectRe: [patches] [PATCH 17/17] RISC-V: Build Infastructure
Message-ID<u7kRZ-3fc-11@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote:
> This patch contains all the build infastructure that actually enables
> the RISC-V port.  This includes Makefiles, linker scripts, and Kconfig
> files.  It also contains the only top-level change, which adds RISC-V to
> the list of architectures that need a sed run to produce the ARCH
> variable when building locally.
> 
> Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
> ---
[...]
> +config ISA_C
> +	bool "Emit compressed instructions when building Linux"

As a user, I'd prefer to have slightly more globally-recognisable names
than ISA_<single letter> for RISC-V instruction set architecture
extensions. A quick "git grep -A2 'config ISA'" shows the following
Kconfig symbols:

* ISA, ISA_BUS_API, ISA_DMA_API, ISAPNP:
  Settings related to the historic ISA bus.
* ISA_ARCOMPACT/ISA_ARCV2 (arch/arc),
  ISA_M32R/ISA_M32R2/ISA_DSP_LEVEL2/ISA_DUAL_ISSUE (arch/m32r):
  Instruction set options.

Four out of the six instruction set options have ARC/M32R in the name,
and I think that makes things slightly more readable. Therefore I
humbly propose something longer, and with a hint of RISC-V in the name,
such as ISA_RVC.

(Take this with a grain of salt, perhaps.)


Jonathan Neuschäfer

[toc] | [next] | [standalone]


#1696783

FromPalmer Dabbelt <palmer@dabbelt.com>
Date2017-07-26 07:30 +0200
Message-ID<u7n3s-4zl-11@gated-at.bofh.it>
In reply to#1696751
On Tue, 25 Jul 2017 19:57:17 PDT (-0700), j.neuschaefer@gmx.net wrote:
> On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote:
>> This patch contains all the build infastructure that actually enables
>> the RISC-V port.  This includes Makefiles, linker scripts, and Kconfig
>> files.  It also contains the only top-level change, which adds RISC-V to
>> the list of architectures that need a sed run to produce the ARCH
>> variable when building locally.
>>
>> Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
>> ---
> [...]
>> +config ISA_C
>> +	bool "Emit compressed instructions when building Linux"
>
> As a user, I'd prefer to have slightly more globally-recognisable names
> than ISA_<single letter> for RISC-V instruction set architecture
> extensions. A quick "git grep -A2 'config ISA'" shows the following
> Kconfig symbols:
>
> * ISA, ISA_BUS_API, ISA_DMA_API, ISAPNP:
>   Settings related to the historic ISA bus.
> * ISA_ARCOMPACT/ISA_ARCV2 (arch/arc),
>   ISA_M32R/ISA_M32R2/ISA_DSP_LEVEL2/ISA_DUAL_ISSUE (arch/m32r):
>   Instruction set options.
>
> Four out of the six instruction set options have ARC/M32R in the name,
> and I think that makes things slightly more readable. Therefore I
> humbly propose something longer, and with a hint of RISC-V in the name,
> such as ISA_RVC.
>
> (Take this with a grain of salt, perhaps.)

Good timing: I was about to submit a v6 patch set.  I'm cool with
CONFIG_ISA_RVC and friends, do you mind submitting a patch?

[toc] | [prev] | [next] | [standalone]


#1696829

FromArnd Bergmann <arnd@arndb.de>
Date2017-07-26 09:00 +0200
Message-ID<u7osy-5jS-21@gated-at.bofh.it>
In reply to#1696783
On Wed, Jul 26, 2017 at 7:20 AM, Palmer Dabbelt <palmer@dabbelt.com> wrote:
> On Tue, 25 Jul 2017 19:57:17 PDT (-0700), j.neuschaefer@gmx.net wrote:
>> On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote:
>>> This patch contains all the build infastructure that actually enables
>>> the RISC-V port.  This includes Makefiles, linker scripts, and Kconfig
>>> files.  It also contains the only top-level change, which adds RISC-V to
>>> the list of architectures that need a sed run to produce the ARCH
>>> variable when building locally.
>>>
>>> Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
>>> ---
>> [...]
>>> +config ISA_C
>>> +    bool "Emit compressed instructions when building Linux"
>>
>> As a user, I'd prefer to have slightly more globally-recognisable names
>> than ISA_<single letter> for RISC-V instruction set architecture
>> extensions. A quick "git grep -A2 'config ISA'" shows the following
>> Kconfig symbols:
>
> Good timing: I was about to submit a v6 patch set.  I'm cool with
> CONFIG_ISA_RVC and friends, do you mind submitting a patch?

I'd generally prefix those highly architecture specific ones with the
architecture name, e.g. CONFIG_RISCV_ISA_C

      Arnd

[toc] | [prev] | [next] | [standalone]


#1697477

FromJonathan Neuschäfer <j.neuschaefer@gmx.net>
Date2017-07-26 20:50 +0200
Message-ID<u7zxD-3Wx-1@gated-at.bofh.it>
In reply to#1696783

[Multipart message — attachments visible in raw view] — view raw

On Tue, Jul 25, 2017 at 10:20:50PM -0700, Palmer Dabbelt wrote:
> On Tue, 25 Jul 2017 19:57:17 PDT (-0700), j.neuschaefer@gmx.net wrote:
> > On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote:
[...]
> >> +config ISA_C
> >> +	bool "Emit compressed instructions when building Linux"
> >
> > As a user, I'd prefer to have slightly more globally-recognisable names
> > than ISA_<single letter> for RISC-V instruction set architecture
> > extensions. A quick "git grep -A2 'config ISA'" shows the following
> > Kconfig symbols:
> >
> > * ISA, ISA_BUS_API, ISA_DMA_API, ISAPNP:
> >   Settings related to the historic ISA bus.
> > * ISA_ARCOMPACT/ISA_ARCV2 (arch/arc),
> >   ISA_M32R/ISA_M32R2/ISA_DSP_LEVEL2/ISA_DUAL_ISSUE (arch/m32r):
> >   Instruction set options.
> >
> > Four out of the six instruction set options have ARC/M32R in the name,
> > and I think that makes things slightly more readable. Therefore I
> > humbly propose something longer, and with a hint of RISC-V in the name,
> > such as ISA_RVC.
> >
> > (Take this with a grain of salt, perhaps.)
> 
> Good timing: I was about to submit a v6 patch set.  I'm cool with
> CONFIG_ISA_RVC and friends, do you mind submitting a patch?

I'm not sure about ISA_A, because as I understand the mails in one of
the previous review threads, RVA is now required by Linux, so there
shouldn't be a need for CONFIG_ISA_A (or an equivalent option).

CONFIG_RISCV_ISA_C (which Arnd suggested) makes it even clearer that
these are RISC-V related options.

Here's my patch, for reference (untested, because I currently don't have
a riscv compiler installed):


Subject: [PATCH] RISC-V: Rename CONFIG_ISA_C to CONFIG_ISA_RVC

To make it clearer that ISA_C is a RISC-V related option, rename it to
ISA_RVC.

Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net>
---
 arch/riscv/Kconfig  | 2 +-
 arch/riscv/Makefile | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig
index cc274bbc29a7..8c43e5c73892 100644
--- a/arch/riscv/Kconfig
+++ b/arch/riscv/Kconfig
@@ -135,7 +135,7 @@ config TUNE_GENERIC
 
 endchoice
 
-config ISA_C
+config ISA_RVC
 	bool "Emit compressed instructions when building Linux"
 	default n
 	help
diff --git a/arch/riscv/Makefile b/arch/riscv/Makefile
index 66c4a5e383f9..7ac91bcf9fe7 100644
--- a/arch/riscv/Makefile
+++ b/arch/riscv/Makefile
@@ -40,7 +40,7 @@ KBUILD_CFLAGS += -Wall
 ifeq ($(CONFIG_ISA_A),y)
 	KBUILD_ARCH_A = a
 endif
-ifeq ($(CONFIG_ISA_C),y)
+ifeq ($(CONFIG_ISA_RVC),y)
 	KBUILD_ARCH_C = c
 endif
 
-- 
2.11.0

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web