Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1696751

Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure

From Jonathan Neuschäfer <j.neuschaefer@gmx.net>
Newsgroups linux.kernel
Subject Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure
Date 2017-07-26 05:10 +0200
Message-ID <u7kRZ-3fc-11@gated-at.bofh.it> (permalink)
References <u2eNc-1ui-3@gated-at.bofh.it> <u2eNd-1ui-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote:
> This patch contains all the build infastructure that actually enables
> the RISC-V port.  This includes Makefiles, linker scripts, and Kconfig
> files.  It also contains the only top-level change, which adds RISC-V to
> the list of architectures that need a sed run to produce the ARCH
> variable when building locally.
> 
> Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
> ---
[...]
> +config ISA_C
> +	bool "Emit compressed instructions when building Linux"

As a user, I'd prefer to have slightly more globally-recognisable names
than ISA_<single letter> for RISC-V instruction set architecture
extensions. A quick "git grep -A2 'config ISA'" shows the following
Kconfig symbols:

* ISA, ISA_BUS_API, ISA_DMA_API, ISAPNP:
  Settings related to the historic ISA bus.
* ISA_ARCOMPACT/ISA_ARCV2 (arch/arc),
  ISA_M32R/ISA_M32R2/ISA_DSP_LEVEL2/ISA_DUAL_ISSUE (arch/m32r):
  Instruction set options.

Four out of the six instruction set options have ARC/M32R in the name,
and I think that makes things slightly more readable. Therefore I
humbly propose something longer, and with a hint of RISC-V in the name,
such as ISA_RVC.

(Take this with a grain of salt, perhaps.)


Jonathan Neuschäfer

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Jonathan Neuschäfer <j.neuschaefer@gmx.net> - 2017-07-26 05:10 +0200
  Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Palmer Dabbelt <palmer@dabbelt.com> - 2017-07-26 07:30 +0200
    Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Arnd Bergmann <arnd@arndb.de> - 2017-07-26 09:00 +0200
    Re: [patches] [PATCH 17/17] RISC-V: Build Infastructure Jonathan Neuschäfer <j.neuschaefer@gmx.net> - 2017-07-26 20:50 +0200

csiph-web