Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1688189 > unrolled thread
| Started by | Christophe JAILLET <christophe.jaillet@wanadoo.fr> |
|---|---|
| First post | 2017-07-16 13:10 +0200 |
| Last post | 2017-07-17 21:40 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] i40iw: Simplify code Christophe JAILLET <christophe.jaillet@wanadoo.fr> - 2017-07-16 13:10 +0200
Re: [PATCH] i40iw: Simplify code Joe Perches <joe@perches.com> - 2017-07-16 17:20 +0200
Re: [PATCH] i40iw: Simplify code Shiraz Saleem <shiraz.saleem@intel.com> - 2017-07-17 21:40 +0200
| From | Christophe JAILLET <christophe.jaillet@wanadoo.fr> |
|---|---|
| Date | 2017-07-16 13:10 +0200 |
| Subject | [PATCH] i40iw: Simplify code |
| Message-ID | <u3PAZ-6Cr-17@gated-at.bofh.it> |
Axe a few lines of code and re-use existing error handling path to avoid
code duplication.
Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
drivers/infiniband/hw/i40iw/i40iw_pble.c | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/drivers/infiniband/hw/i40iw/i40iw_pble.c b/drivers/infiniband/hw/i40iw/i40iw_pble.c
index c87ba1617087..540aab5e502d 100644
--- a/drivers/infiniband/hw/i40iw/i40iw_pble.c
+++ b/drivers/infiniband/hw/i40iw/i40iw_pble.c
@@ -269,10 +269,8 @@ static enum i40iw_status_code add_bp_pages(struct i40iw_sc_dev *dev,
status = i40iw_add_sd_table_entry(dev->hw, hmc_info,
info->idx.sd_idx, I40IW_SD_TYPE_PAGED,
I40IW_HMC_DIRECT_BP_SIZE);
- if (status) {
- i40iw_free_vmalloc_mem(dev->hw, chunk);
- return status;
- }
+ if (status)
+ goto error;
if (!dev->is_pf) {
status = i40iw_vchnl_vf_add_hmc_objs(dev, I40IW_HMC_IW_PBLE,
fpm_to_idx(pble_rsrc,
@@ -280,8 +278,7 @@ static enum i40iw_status_code add_bp_pages(struct i40iw_sc_dev *dev,
(info->pages << PBLE_512_SHIFT));
if (status) {
i40iw_pr_err("allocate PBLEs in the PF. Error %i\n", status);
- i40iw_free_vmalloc_mem(dev->hw, chunk);
- return status;
+ goto error;
}
}
addr = chunk->vaddr;
--
2.11.0
[toc] | [next] | [standalone]
| From | Joe Perches <joe@perches.com> |
|---|---|
| Date | 2017-07-16 17:20 +0200 |
| Message-ID | <u3TuV-Kd-15@gated-at.bofh.it> |
| In reply to | #1688189 |
On Sun, 2017-07-16 at 13:09 +0200, Christophe JAILLET wrote:
> Axe a few lines of code and re-use existing error handling path to avoid
> code duplication.
unrelated:
> diff --git a/drivers/infiniband/hw/i40iw/i40iw_pble.c b/drivers/infiniband/hw/i40iw/i40iw_pble.c
[]
> @@ -280,8 +278,7 @@ static enum i40iw_status_code add_bp_pages(struct i40iw_sc_dev *dev,
> (info->pages << PBLE_512_SHIFT));
> if (status) {
> i40iw_pr_err("allocate PBLEs in the PF. Error %i\n", status);
It'd be nice if i40iw_pr_<err|warn|info> were removed and
converted into dev_<err|warn|info> or netdev_<err|warn|info>.
[toc] | [prev] | [next] | [standalone]
| From | Shiraz Saleem <shiraz.saleem@intel.com> |
|---|---|
| Date | 2017-07-17 21:40 +0200 |
| Message-ID | <u4k26-LB-17@gated-at.bofh.it> |
| In reply to | #1688189 |
On Sun, Jul 16, 2017 at 01:09:23PM +0200, Christophe JAILLET wrote: > Axe a few lines of code and re-use existing error handling path to avoid > code duplication. > Acked-by: Shiraz Saleem <shiraz.saleem@intel.com>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web