Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1688494
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] i40iw: Simplify code |
| Date | 2017-07-16 17:20 +0200 |
| Message-ID | <u3TuV-Kd-15@gated-at.bofh.it> (permalink) |
| References | <u3PAZ-6Cr-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sun, 2017-07-16 at 13:09 +0200, Christophe JAILLET wrote:
> Axe a few lines of code and re-use existing error handling path to avoid
> code duplication.
unrelated:
> diff --git a/drivers/infiniband/hw/i40iw/i40iw_pble.c b/drivers/infiniband/hw/i40iw/i40iw_pble.c
[]
> @@ -280,8 +278,7 @@ static enum i40iw_status_code add_bp_pages(struct i40iw_sc_dev *dev,
> (info->pages << PBLE_512_SHIFT));
> if (status) {
> i40iw_pr_err("allocate PBLEs in the PF. Error %i\n", status);
It'd be nice if i40iw_pr_<err|warn|info> were removed and
converted into dev_<err|warn|info> or netdev_<err|warn|info>.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] i40iw: Simplify code Christophe JAILLET <christophe.jaillet@wanadoo.fr> - 2017-07-16 13:10 +0200 Re: [PATCH] i40iw: Simplify code Joe Perches <joe@perches.com> - 2017-07-16 17:20 +0200 Re: [PATCH] i40iw: Simplify code Shiraz Saleem <shiraz.saleem@intel.com> - 2017-07-17 21:40 +0200
csiph-web