Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1688669 > unrolled thread

[PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options

Started byKrzysztof Kozlowski <krzk@kernel.org>
First post2017-07-17 08:00 +0200
Last post2017-07-17 18:40 +0200
Articles 9 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 08:00 +0200
    [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 08:00 +0200
      Re: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options Geert Uytterhoeven <geert@linux-m68k.org> - 2017-07-17 09:30 +0200
        Re: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing  options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 18:40 +0200
    [PATCH 3/6] ARM: ixp4xx_defconfig: Cleanup from non-existing options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 08:00 +0200
    [PATCH 6/6] ARM: qcom_defconfig: Cleanup from non-existing options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 08:00 +0200
    [PATCH 5/6] ARM: ezx_defconfig: Cleanup from non-existing options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 08:00 +0200
    Re: [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options Geert Uytterhoeven <geert@linux-m68k.org> - 2017-07-17 09:30 +0200
      Re: [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing  options Krzysztof Kozlowski <krzk@kernel.org> - 2017-07-17 18:40 +0200

#1688669 — [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 08:00 +0200
Subject[PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options
Message-ID<u47ey-Xp-5@gated-at.bofh.it>
Remove options which do not exist anymore:
 - TEGRA_EMC_SCALING_ENABLE is gone since commit cab4d50389c6 ("ARM:
   tegra: remove TEGRA_EMC_SCALING_ENABLE");

 - ARCH_VEXPRESS_CA9X4 is gone since commit 81cc3f868d30
   ("ARM: vexpress: Remove non-DT code");

 - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
   commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
   implementation with DRM bridge");

 - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
   d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
   phase3");

 - OMAP_USB3 was replaced by TI_PIPE3 in commit a70143bbef6b ("drivers:
   phy: usb3/pipe3: Adapt pipe3 driver to Generic PHY Framework");

 - MMC_DW_IDMAC is gone since commit 3fc7eaef44db ("mmc: dw_mmc: Add
   external dma interface support");

 - QCOM_SMD since commit 395a48053af6 ("soc: qcom: smd: Remove
   standalone driver");

 - COMMON_CLK_MAX77802 was merged into COMMON_CLK_MAX77686 in commit
   8ad313fe4e00 ("clk: max77686: Combine Maxim max77686 and max77802
   driver");

 - CRYPTO_DEV_TEGRA_AES is gone since commit 645af2e43705 ("crypto:
   tegra - remove driver");

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
 arch/arm/configs/multi_v7_defconfig | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)

diff --git a/arch/arm/configs/multi_v7_defconfig b/arch/arm/configs/multi_v7_defconfig
index 4d19c1b4b8e7..75c227600298 100644
--- a/arch/arm/configs/multi_v7_defconfig
+++ b/arch/arm/configs/multi_v7_defconfig
@@ -104,13 +104,11 @@ CONFIG_ARCH_TEGRA_2x_SOC=y
 CONFIG_ARCH_TEGRA_3x_SOC=y
 CONFIG_ARCH_TEGRA_114_SOC=y
 CONFIG_ARCH_TEGRA_124_SOC=y
-CONFIG_TEGRA_EMC_SCALING_ENABLE=y
 CONFIG_ARCH_UNIPHIER=y
 CONFIG_ARCH_U8500=y
 CONFIG_MACH_HREFV60=y
 CONFIG_MACH_SNOWBALL=y
 CONFIG_ARCH_VEXPRESS=y
-CONFIG_ARCH_VEXPRESS_CA9X4=y
 CONFIG_ARCH_VEXPRESS_TC2_PM=y
 CONFIG_ARCH_WM8850=y
 CONFIG_ARCH_ZYNQ=y
@@ -603,7 +601,6 @@ CONFIG_ROCKCHIP_DW_MIPI_DSI=y
 CONFIG_ROCKCHIP_INNO_HDMI=y
 CONFIG_DRM_ATMEL_HLCDC=m
 CONFIG_DRM_RCAR_DU=m
-CONFIG_DRM_RCAR_HDMI=y
 CONFIG_DRM_RCAR_LVDS=y
 CONFIG_DRM_SUN4I=m
 CONFIG_DRM_TEGRA=y
@@ -650,7 +647,6 @@ CONFIG_SND_SOC_SMDK_WM8994_PCM=m
 CONFIG_SND_SOC_SNOW=m
 CONFIG_SND_SOC_SH4_FSI=m
 CONFIG_SND_SOC_RCAR=m
-CONFIG_SND_SOC_RSRC_CARD=m
 CONFIG_SND_SUN4I_CODEC=m
 CONFIG_SND_SOC_TEGRA=m
 CONFIG_SND_SOC_TEGRA_RT5640=m
@@ -667,6 +663,7 @@ CONFIG_SND_SOC_WM8978=m
 CONFIG_SND_SOC_STI=m
 CONFIG_SND_SOC_STI_SAS=m
 CONFIG_SND_SIMPLE_CARD=m
+CONFIG_SND_SIMPLE_SCU_CARD=m
 CONFIG_USB=y
 CONFIG_USB_XHCI_HCD=y
 CONFIG_USB_XHCI_MVEBU=y
@@ -695,7 +692,6 @@ CONFIG_USB_CHIPIDEA_UDC=y
 CONFIG_USB_CHIPIDEA_HOST=y
 CONFIG_AB8500_USB=y
 CONFIG_KEYSTONE_USB_PHY=y
-CONFIG_OMAP_USB3=y
 CONFIG_USB_GPIO_VBUS=y
 CONFIG_USB_ISP1301=y
 CONFIG_USB_MSM_OTG=m
@@ -728,7 +724,6 @@ CONFIG_MMC_SDHCI_MSM=y
 CONFIG_MMC_MVSDIO=y
 CONFIG_MMC_SDHI=y
 CONFIG_MMC_DW=y
-CONFIG_MMC_DW_IDMAC=y
 CONFIG_MMC_DW_PLTFM=y
 CONFIG_MMC_DW_EXYNOS=y
 CONFIG_MMC_DW_ROCKCHIP=y
@@ -825,7 +820,6 @@ CONFIG_BCMA_DRIVER_GPIO=y
 CONFIG_QCOM_GSBI=y
 CONFIG_QCOM_PM=y
 CONFIG_QCOM_SMEM=y
-CONFIG_QCOM_SMD=y
 CONFIG_QCOM_SMD_RPM=y
 CONFIG_QCOM_SMP2P=y
 CONFIG_QCOM_SMSM=y
@@ -837,7 +831,6 @@ CONFIG_CHROME_PLATFORMS=y
 CONFIG_STAGING_BOARD=y
 CONFIG_CROS_EC_CHARDEV=m
 CONFIG_COMMON_CLK_MAX77686=y
-CONFIG_COMMON_CLK_MAX77802=m
 CONFIG_COMMON_CLK_RK808=m
 CONFIG_COMMON_CLK_S2MPS11=m
 CONFIG_APQ_MMCC_8084=y
@@ -933,7 +926,6 @@ CONFIG_PRINTK_TIME=y
 CONFIG_DEBUG_FS=y
 CONFIG_MAGIC_SYSRQ=y
 CONFIG_LOCKUP_DETECTOR=y
-CONFIG_CRYPTO_DEV_TEGRA_AES=y
 CONFIG_CPUFREQ_DT=y
 CONFIG_KEYSTONE_IRQ=y
 CONFIG_HW_RANDOM=y
-- 
2.7.4

[toc] | [next] | [standalone]


#1688670 — [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 08:00 +0200
Subject[PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options
Message-ID<u47ey-Xp-7@gated-at.bofh.it>
In reply to#1688669
Remove options which do not exist anymore:
 - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
   commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
   implementation with DRM bridge");

 - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
   d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
   phase3");

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
 arch/arm/configs/shmobile_defconfig | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/arm/configs/shmobile_defconfig b/arch/arm/configs/shmobile_defconfig
index 3c66a422fb4d..123a1debe3d7 100644
--- a/arch/arm/configs/shmobile_defconfig
+++ b/arch/arm/configs/shmobile_defconfig
@@ -155,7 +155,6 @@ CONFIG_VIDEO_ML86V7667=y
 CONFIG_DRM=y
 CONFIG_DRM_I2C_ADV7511=y
 CONFIG_DRM_RCAR_DU=y
-CONFIG_DRM_RCAR_HDMI=y
 CONFIG_DRM_RCAR_LVDS=y
 CONFIG_FB_SH_MOBILE_LCDC=y
 CONFIG_FB_SH_MOBILE_MERAM=y
@@ -169,9 +168,9 @@ CONFIG_SND=y
 CONFIG_SND_SOC=y
 CONFIG_SND_SOC_SH4_FSI=y
 CONFIG_SND_SOC_RCAR=y
-CONFIG_SND_SOC_RSRC_CARD=y
 CONFIG_SND_SOC_AK4642=y
 CONFIG_SND_SOC_WM8978=y
+CONFIG_SND_SIMPLE_SCU_CARD=y
 CONFIG_USB=y
 CONFIG_USB_XHCI_HCD=y
 CONFIG_USB_XHCI_RCAR=y
-- 
2.7.4

[toc] | [prev] | [next] | [standalone]


#1688718 — Re: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options

FromGeert Uytterhoeven <geert@linux-m68k.org>
Date2017-07-17 09:30 +0200
SubjectRe: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options
Message-ID<u48DD-1Za-5@gated-at.bofh.it>
In reply to#1688670
Hi Krzysztof,

On Mon, Jul 17, 2017 at 7:49 AM, Krzysztof Kozlowski <krzk@kernel.org> wrote:
> Remove options which do not exist anymore:
>  - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
>    commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
>    implementation with DRM bridge");
>
>  - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
>    d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
>    phase3");
>
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

These have already be fixed in the defconfig-for-v4.14 branch Simon Horman's
tree (git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git).

https://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git/log/?h=defconfig-for-v4.14

They're not yet in -next as v4.13-rc1 wasn't released at that time, and
Simon is now on holidays.

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

[toc] | [prev] | [next] | [standalone]


#1689250 — Re: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 18:40 +0200
SubjectRe: [PATCH 2/6] ARM: shmobile_defconfig: Cleanup from non-existing options
Message-ID<u4hdW-7rt-57@gated-at.bofh.it>
In reply to#1688718
On Mon, Jul 17, 2017 at 09:29:24AM +0200, Geert Uytterhoeven wrote:
> Hi Krzysztof,
> 
> On Mon, Jul 17, 2017 at 7:49 AM, Krzysztof Kozlowski <krzk@kernel.org> wrote:
> > Remove options which do not exist anymore:
> >  - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
> >    commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
> >    implementation with DRM bridge");
> >
> >  - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
> >    d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
> >    phase3");
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> These have already be fixed in the defconfig-for-v4.14 branch Simon Horman's
> tree (git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git).
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git/log/?h=defconfig-for-v4.14
> 
> They're not yet in -next as v4.13-rc1 wasn't released at that time, and
> Simon is now on holidays.

Ahhh, thanks for noticing this!

Best regards,
Krzysztof

[toc] | [prev] | [next] | [standalone]


#1688671 — [PATCH 3/6] ARM: ixp4xx_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 08:00 +0200
Subject[PATCH 3/6] ARM: ixp4xx_defconfig: Cleanup from non-existing options
Message-ID<u47ey-Xp-13@gated-at.bofh.it>
In reply to#1688669
Remove options which do not exist anymore:
 - ECONET is gone since commit 349f29d841db ("econet: remove ancient bug
   ridden protocol");

 - IPDDP_DECAP is gone since commit 9b5645b51384 ("appletalk: remove
   "config IPDDP_DECAP"");

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
 arch/arm/configs/ixp4xx_defconfig | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/arch/arm/configs/ixp4xx_defconfig b/arch/arm/configs/ixp4xx_defconfig
index c8378da71913..8c3c99cd6de9 100644
--- a/arch/arm/configs/ixp4xx_defconfig
+++ b/arch/arm/configs/ixp4xx_defconfig
@@ -81,12 +81,8 @@ CONFIG_ATALK=m
 CONFIG_DEV_APPLETALK=m
 CONFIG_IPDDP=m
 CONFIG_IPDDP_ENCAP=y
-CONFIG_IPDDP_DECAP=y
 CONFIG_X25=m
 CONFIG_LAPB=m
-CONFIG_ECONET=m
-CONFIG_ECONET_AUNUDP=y
-CONFIG_ECONET_NATIVE=y
 CONFIG_WAN_ROUTER=m
 CONFIG_NET_SCHED=y
 CONFIG_NET_SCH_CBQ=m
-- 
2.7.4

[toc] | [prev] | [next] | [standalone]


#1688672 — [PATCH 6/6] ARM: qcom_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 08:00 +0200
Subject[PATCH 6/6] ARM: qcom_defconfig: Cleanup from non-existing options
Message-ID<u47ez-Xp-17@gated-at.bofh.it>
In reply to#1688669
QCOM_SMD is gone since commit 395a48053af6 ("soc: qcom: smd: Remove
standalone driver").

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
 arch/arm/configs/qcom_defconfig | 1 -
 1 file changed, 1 deletion(-)

diff --git a/arch/arm/configs/qcom_defconfig b/arch/arm/configs/qcom_defconfig
index b02039c712c3..879159e4ab58 100644
--- a/arch/arm/configs/qcom_defconfig
+++ b/arch/arm/configs/qcom_defconfig
@@ -199,7 +199,6 @@ CONFIG_QCOM_WCNSS_PIL=y
 CONFIG_QCOM_GSBI=y
 CONFIG_QCOM_PM=y
 CONFIG_QCOM_SMEM=y
-CONFIG_QCOM_SMD=y
 CONFIG_QCOM_SMD_RPM=y
 CONFIG_QCOM_SMP2P=y
 CONFIG_QCOM_SMSM=y
-- 
2.7.4

[toc] | [prev] | [next] | [standalone]


#1688673 — [PATCH 5/6] ARM: ezx_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 08:00 +0200
Subject[PATCH 5/6] ARM: ezx_defconfig: Cleanup from non-existing options
Message-ID<u47ez-Xp-19@gated-at.bofh.it>
In reply to#1688669
CPU_FREQ_DEBUG is gone since commit 2d06d8c49afd  ("[CPUFREQ] use
dynamic debug instead of custom infrastructure").

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
 arch/arm/configs/ezx_defconfig | 1 -
 1 file changed, 1 deletion(-)

diff --git a/arch/arm/configs/ezx_defconfig b/arch/arm/configs/ezx_defconfig
index 23660f3d0f7f..484e51fbd4a6 100644
--- a/arch/arm/configs/ezx_defconfig
+++ b/arch/arm/configs/ezx_defconfig
@@ -27,7 +27,6 @@ CONFIG_ZBOOT_ROM_BSS=0x0
 CONFIG_CMDLINE="console=tty1 root=/dev/mmcblk0p2 rootfstype=ext2 rootdelay=3 ip=192.168.0.202:192.168.0.200:192.168.0.200:255.255.255.0 debug"
 CONFIG_KEXEC=y
 CONFIG_CPU_FREQ=y
-CONFIG_CPU_FREQ_DEBUG=y
 CONFIG_CPU_FREQ_GOV_POWERSAVE=m
 CONFIG_CPU_FREQ_GOV_USERSPACE=m
 CONFIG_CPU_FREQ_GOV_ONDEMAND=m
-- 
2.7.4

[toc] | [prev] | [next] | [standalone]


#1688719

FromGeert Uytterhoeven <geert@linux-m68k.org>
Date2017-07-17 09:30 +0200
Message-ID<u48DD-1Za-11@gated-at.bofh.it>
In reply to#1688669
Hi Krzysztof,

On Mon, Jul 17, 2017 at 7:49 AM, Krzysztof Kozlowski <krzk@kernel.org> wrote:
> Remove options which do not exist anymore:

<snip>

>  - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
>    commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
>    implementation with DRM bridge");
>
>  - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
>    d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
>    phase3");

These have already be fixed in the defconfig-for-v4.14 branch Simon Horman's
tree (git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git).
They're not yet in -next as v4.13-rc1 wasn't released at that time, and
Simon is noew on holidays.

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

[toc] | [prev] | [next] | [standalone]


#1689249 — Re: [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options

FromKrzysztof Kozlowski <krzk@kernel.org>
Date2017-07-17 18:40 +0200
SubjectRe: [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options
Message-ID<u4hdW-7rt-55@gated-at.bofh.it>
In reply to#1688719
On Mon, Jul 17, 2017 at 09:28:09AM +0200, Geert Uytterhoeven wrote:
> Hi Krzysztof,
> 
> On Mon, Jul 17, 2017 at 7:49 AM, Krzysztof Kozlowski <krzk@kernel.org> wrote:
> > Remove options which do not exist anymore:
> 
> <snip>
> 
> >  - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
> >    commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
> >    implementation with DRM bridge");
> >
> >  - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
> >    d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
> >    phase3");
> 
> These have already be fixed in the defconfig-for-v4.14 branch Simon Horman's
> tree (git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git).
> They're not yet in -next as v4.13-rc1 wasn't released at that time, and
> Simon is noew on holidays.

I'll rebase then on top of his branch.

Best regards,
Krzysztof

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web