Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1682091 > unrolled thread

Re: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup

Started byStephen Boyd <sboyd@codeaurora.org>
First post2017-07-06 09:00 +0200
Last post2017-07-07 17:00 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup Stephen Boyd <sboyd@codeaurora.org> - 2017-07-06 09:00 +0200
    Re: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup kgunda@codeaurora.org - 2017-07-07 17:00 +0200

#1682091 — Re: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup

FromStephen Boyd <sboyd@codeaurora.org>
Date2017-07-06 09:00 +0200
SubjectRe: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup
Message-ID<u08VA-Sf-9@gated-at.bofh.it>
On 07/03, Kiran Gunda wrote:
> This patch cleans up the following.
> 
> - Rename the "pa" to "pmic_arb".
> - Rename the spmi_pmic_arb *dev to spmi_pmic_arb *pmic_arb.
> - Rename the pa_{read,write}_data() functions to
>   pmic_arb_{read,write}_data().
> - Rename channel to APID.
> - Rename the HWIRQ_*() macros to hwirq_to_*().
> - Clean up qpnpint_irq_set_type() and pmic_arb_find_apid()
>   functions.
> 
> Signed-off-by: Kiran Gunda <kgunda@codeaurora.org>
> ---
>  drivers/spmi/spmi-pmic-arb.c | 454 +++++++++++++++++++++----------------------
>  1 file changed, 227 insertions(+), 227 deletions(-)
> 

This patch is large and noisy. Have you tried running
scripts/objdiff on this to make sure nothing changed?

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

[toc] | [next] | [standalone]


#1683232

Fromkgunda@codeaurora.org
Date2017-07-07 17:00 +0200
Message-ID<u0CTE-5qc-11@gated-at.bofh.it>
In reply to#1682091
On 2017-07-06 12:19, Stephen Boyd wrote:
> On 07/03, Kiran Gunda wrote:
>> This patch cleans up the following.
>> 
>> - Rename the "pa" to "pmic_arb".
>> - Rename the spmi_pmic_arb *dev to spmi_pmic_arb *pmic_arb.
>> - Rename the pa_{read,write}_data() functions to
>>   pmic_arb_{read,write}_data().
>> - Rename channel to APID.
>> - Rename the HWIRQ_*() macros to hwirq_to_*().
>> - Clean up qpnpint_irq_set_type() and pmic_arb_find_apid()
>>   functions.
>> 
>> Signed-off-by: Kiran Gunda <kgunda@codeaurora.org>
>> ---
>>  drivers/spmi/spmi-pmic-arb.c | 454 
>> +++++++++++++++++++++----------------------
>>  1 file changed, 227 insertions(+), 227 deletions(-)
>> 
> 
> This patch is large and noisy. Have you tried running
> scripts/objdiff on this to make sure nothing changed?
The objdiff will not be helpful here as this patch is for
the renaming and clean-up to address your multiple minor
comments on the earlier patches, which has minor code changes.

I have keenly checked the patch and made sure that there are no
unintended changes, except (+ *   v2 only.) one extra line in
documentation of struct apid_data {. I will remove this and
upload the next patch.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web