Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1621039 > unrolled thread
| Started by | Juergen Gross <jgross@suse.com> |
|---|---|
| First post | 2017-04-11 11:00 +0200 |
| Last post | 2017-04-11 11:40 +0200 |
| Articles | 4 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Juergen Gross <jgross@suse.com> - 2017-04-11 11:00 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Oleksandr Andrushchenko <andr2000@gmail.com> - 2017-04-11 11:30 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Juergen Gross <jgross@suse.com> - 2017-04-11 11:40 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Oleksandr Andrushchenko <andr2000@gmail.com> - 2017-04-11 11:40 +0200
| From | Juergen Gross <jgross@suse.com> |
|---|---|
| Date | 2017-04-11 11:00 +0200 |
| Subject | [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution |
| Message-ID | <tuZOy-4F4-7@gated-at.bofh.it> |
Add a parameter for setting the resolution of xen-kbdfront in order to
be able to cope with a (virtual) frame buffer of arbitrary resolution.
Signed-off-by: Juergen Gross <jgross@suse.com>
---
drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)
diff --git a/drivers/input/misc/xen-kbdfront.c b/drivers/input/misc/xen-kbdfront.c
index 3900875dec10..90e7981a7768 100644
--- a/drivers/input/misc/xen-kbdfront.c
+++ b/drivers/input/misc/xen-kbdfront.c
@@ -41,6 +41,12 @@ struct xenkbd_info {
char phys[32];
};
+enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
+static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
+module_param_array(size, int, NULL, 0444);
+MODULE_PARM_DESC(size,
+ "Pointing device width, height in pixels (default 800,600)");
+
static int xenkbd_remove(struct xenbus_device *);
static int xenkbd_connect_backend(struct xenbus_device *, struct xenkbd_info *);
static void xenkbd_disconnect_backend(struct xenkbd_info *);
@@ -174,8 +180,8 @@ static int xenkbd_probe(struct xenbus_device *dev,
if (abs) {
__set_bit(EV_ABS, ptr->evbit);
- input_set_abs_params(ptr, ABS_X, 0, XENFB_WIDTH, 0, 0);
- input_set_abs_params(ptr, ABS_Y, 0, XENFB_HEIGHT, 0, 0);
+ input_set_abs_params(ptr, ABS_X, 0, size[KPARAM_WIDTH], 0, 0);
+ input_set_abs_params(ptr, ABS_Y, 0, size[KPARAM_HEIGHT], 0, 0);
} else {
input_set_capability(ptr, EV_REL, REL_X);
input_set_capability(ptr, EV_REL, REL_Y);
@@ -344,12 +350,16 @@ static void xenkbd_backend_changed(struct xenbus_device *dev,
/* Set input abs params to match backend screen res */
if (xenbus_scanf(XBT_NIL, info->xbdev->otherend,
- "width", "%d", &val) > 0)
+ "width", "%d", &val) > 0) {
input_set_abs_params(info->ptr, ABS_X, 0, val, 0, 0);
+ size[KPARAM_WIDTH] = val;
+ }
if (xenbus_scanf(XBT_NIL, info->xbdev->otherend,
- "height", "%d", &val) > 0)
+ "height", "%d", &val) > 0) {
input_set_abs_params(info->ptr, ABS_Y, 0, val, 0, 0);
+ size[KPARAM_HEIGHT] = val;
+ }
break;
--
2.12.0
[toc] | [next] | [standalone]
| From | Oleksandr Andrushchenko <andr2000@gmail.com> |
|---|---|
| Date | 2017-04-11 11:30 +0200 |
| Subject | Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution |
| Message-ID | <tv0hB-543-29@gated-at.bofh.it> |
| In reply to | #1621039 |
On 04/11/2017 11:50 AM, Juergen Gross wrote:
> Add a parameter for setting the resolution of xen-kbdfront in order to
> be able to cope with a (virtual) frame buffer of arbitrary resolution.
>
> Signed-off-by: Juergen Gross <jgross@suse.com>
> ---
> drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
> 1 file changed, 14 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/input/misc/xen-kbdfront.c b/drivers/input/misc/xen-kbdfront.c
> index 3900875dec10..90e7981a7768 100644
> --- a/drivers/input/misc/xen-kbdfront.c
> +++ b/drivers/input/misc/xen-kbdfront.c
> @@ -41,6 +41,12 @@ struct xenkbd_info {
> char phys[32];
> };
>
> +enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
> +static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
if you are about to release yet another version of the series,
could you please also rename "size" to "ptr_size/pointer_size/XXX",
so later when I add multi-touch support I can have
"mtouch_size" module parameter and they are consistent all together?
> +module_param_array(size, int, NULL, 0444);
> +MODULE_PARM_DESC(size,
> + "Pointing device width, height in pixels (default 800,600)");
> +
> static int xenkbd_remove(struct xenbus_device *);
> static int xenkbd_connect_backend(struct xenbus_device *, struct xenkbd_info *);
> static void xenkbd_disconnect_backend(struct xenkbd_info *);
> @@ -174,8 +180,8 @@ static int xenkbd_probe(struct xenbus_device *dev,
>
> if (abs) {
> __set_bit(EV_ABS, ptr->evbit);
> - input_set_abs_params(ptr, ABS_X, 0, XENFB_WIDTH, 0, 0);
> - input_set_abs_params(ptr, ABS_Y, 0, XENFB_HEIGHT, 0, 0);
> + input_set_abs_params(ptr, ABS_X, 0, size[KPARAM_WIDTH], 0, 0);
> + input_set_abs_params(ptr, ABS_Y, 0, size[KPARAM_HEIGHT], 0, 0);
> } else {
> input_set_capability(ptr, EV_REL, REL_X);
> input_set_capability(ptr, EV_REL, REL_Y);
> @@ -344,12 +350,16 @@ static void xenkbd_backend_changed(struct xenbus_device *dev,
>
> /* Set input abs params to match backend screen res */
> if (xenbus_scanf(XBT_NIL, info->xbdev->otherend,
> - "width", "%d", &val) > 0)
> + "width", "%d", &val) > 0) {
> input_set_abs_params(info->ptr, ABS_X, 0, val, 0, 0);
> + size[KPARAM_WIDTH] = val;
> + }
>
> if (xenbus_scanf(XBT_NIL, info->xbdev->otherend,
> - "height", "%d", &val) > 0)
> + "height", "%d", &val) > 0) {
> input_set_abs_params(info->ptr, ABS_Y, 0, val, 0, 0);
> + size[KPARAM_HEIGHT] = val;
> + }
>
> break;
>
Thank you,
Oleksandr
[toc] | [prev] | [next] | [standalone]
| From | Juergen Gross <jgross@suse.com> |
|---|---|
| Date | 2017-04-11 11:40 +0200 |
| Subject | Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution |
| Message-ID | <tv0rg-57u-13@gated-at.bofh.it> |
| In reply to | #1621084 |
On 11/04/17 11:26, Oleksandr Andrushchenko wrote:
> On 04/11/2017 11:50 AM, Juergen Gross wrote:
>> Add a parameter for setting the resolution of xen-kbdfront in order to
>> be able to cope with a (virtual) frame buffer of arbitrary resolution.
>>
>> Signed-off-by: Juergen Gross <jgross@suse.com>
>> ---
>> drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
>> 1 file changed, 14 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/input/misc/xen-kbdfront.c
>> b/drivers/input/misc/xen-kbdfront.c
>> index 3900875dec10..90e7981a7768 100644
>> --- a/drivers/input/misc/xen-kbdfront.c
>> +++ b/drivers/input/misc/xen-kbdfront.c
>> @@ -41,6 +41,12 @@ struct xenkbd_info {
>> char phys[32];
>> };
>> +enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
>> +static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
> if you are about to release yet another version of the series,
> could you please also rename "size" to "ptr_size/pointer_size/XXX",
> so later when I add multi-touch support I can have
> "mtouch_size" module parameter and they are consistent all together?
Sure. After all I think I can merge the patches, as reading width and
height a second time while connecting the device seems to be pointless.
While logically patch 2 seems to correct the connection process there
was never a problem with it being wrong: width and height would have
been already read during probing of the device so missing to read them
again wouldn't lead to any wrong settings.
Juergen
[toc] | [prev] | [next] | [standalone]
| From | Oleksandr Andrushchenko <andr2000@gmail.com> |
|---|---|
| Date | 2017-04-11 11:40 +0200 |
| Subject | Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution |
| Message-ID | <tv0rg-57u-19@gated-at.bofh.it> |
| In reply to | #1621090 |
On 04/11/2017 12:35 PM, Juergen Gross wrote:
> On 11/04/17 11:26, Oleksandr Andrushchenko wrote:
>> On 04/11/2017 11:50 AM, Juergen Gross wrote:
>>> Add a parameter for setting the resolution of xen-kbdfront in order to
>>> be able to cope with a (virtual) frame buffer of arbitrary resolution.
>>>
>>> Signed-off-by: Juergen Gross <jgross@suse.com>
>>> ---
>>> drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
>>> 1 file changed, 14 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/drivers/input/misc/xen-kbdfront.c
>>> b/drivers/input/misc/xen-kbdfront.c
>>> index 3900875dec10..90e7981a7768 100644
>>> --- a/drivers/input/misc/xen-kbdfront.c
>>> +++ b/drivers/input/misc/xen-kbdfront.c
>>> @@ -41,6 +41,12 @@ struct xenkbd_info {
>>> char phys[32];
>>> };
>>> +enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
>>> +static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
>> if you are about to release yet another version of the series,
>> could you please also rename "size" to "ptr_size/pointer_size/XXX",
>> so later when I add multi-touch support I can have
>> "mtouch_size" module parameter and they are consistent all together?
> Sure. After all I think I can merge the patches, as reading width and
> height a second time while connecting the device seems to be pointless.
>
> While logically patch 2 seems to correct the connection process there
> was never a problem with it being wrong: width and height would have
> been already read during probing of the device so missing to read them
> again wouldn't lead to any wrong settings.
Exactly, IMO this driver does need attention, but it
will also require changes to qemu-fb-backend if state
machine changes. This is why we still use this logic
in our backend as well
>
> Juergen
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web