Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1621090
| From | Juergen Gross <jgross@suse.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution |
| Date | 2017-04-11 11:40 +0200 |
| Message-ID | <tv0rg-57u-13@gated-at.bofh.it> (permalink) |
| References | <tuZOy-4F4-9@gated-at.bofh.it> <tuZOy-4F4-7@gated-at.bofh.it> <tv0hB-543-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 11/04/17 11:26, Oleksandr Andrushchenko wrote:
> On 04/11/2017 11:50 AM, Juergen Gross wrote:
>> Add a parameter for setting the resolution of xen-kbdfront in order to
>> be able to cope with a (virtual) frame buffer of arbitrary resolution.
>>
>> Signed-off-by: Juergen Gross <jgross@suse.com>
>> ---
>> drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
>> 1 file changed, 14 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/input/misc/xen-kbdfront.c
>> b/drivers/input/misc/xen-kbdfront.c
>> index 3900875dec10..90e7981a7768 100644
>> --- a/drivers/input/misc/xen-kbdfront.c
>> +++ b/drivers/input/misc/xen-kbdfront.c
>> @@ -41,6 +41,12 @@ struct xenkbd_info {
>> char phys[32];
>> };
>> +enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
>> +static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
> if you are about to release yet another version of the series,
> could you please also rename "size" to "ptr_size/pointer_size/XXX",
> so later when I add multi-touch support I can have
> "mtouch_size" module parameter and they are consistent all together?
Sure. After all I think I can merge the patches, as reading width and
height a second time while connecting the device seems to be pointless.
While logically patch 2 seems to correct the connection process there
was never a problem with it being wrong: width and height would have
been already read during probing of the device so missing to read them
again wouldn't lead to any wrong settings.
Juergen
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Juergen Gross <jgross@suse.com> - 2017-04-11 11:00 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Oleksandr Andrushchenko <andr2000@gmail.com> - 2017-04-11 11:30 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Juergen Gross <jgross@suse.com> - 2017-04-11 11:40 +0200
Re: [PATCH v2 1/2] xen,input: add xen-kbdfront module parameter for setting resolution Oleksandr Andrushchenko <andr2000@gmail.com> - 2017-04-11 11:40 +0200
csiph-web