Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1612585 > unrolled thread
| Started by | Daeseok Youn <daeseok.youn@gmail.com> |
|---|---|
| First post | 2017-03-30 08:30 +0200 |
| Last post | 2017-03-30 17:50 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() Daeseok Youn <daeseok.youn@gmail.com> - 2017-03-30 08:30 +0200
Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() Alan Cox <alan@linux.intel.com> - 2017-03-30 13:00 +0200
Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() DaeSeok Youn <daeseok.youn@gmail.com> - 2017-03-30 17:50 +0200
| From | Daeseok Youn <daeseok.youn@gmail.com> |
|---|---|
| Date | 2017-03-30 08:30 +0200 |
| Subject | [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() |
| Message-ID | <tqBKN-2aA-1@gated-at.bofh.it> |
The condition line in if-statement is needed to be shorthen to
improve readability.
Signed-off-by: Daeseok Youn <daeseok.youn@gmail.com>
---
drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c b/drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c
index 94bc793..eebfccd 100644
--- a/drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c
+++ b/drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c
@@ -255,14 +255,17 @@ int atomisp_freq_scaling(struct atomisp_device *isp,
struct atomisp_freq_scaling_rule curr_rules;
int i, ret;
unsigned short fps = 0;
+ unsigned short masked_dev = 0;
if (isp->sw_contex.power_state != ATOM_ISP_POWER_UP) {
dev_err(isp->dev, "DFS cannot proceed due to no power.\n");
return -EINVAL;
}
- if ((isp->pdev->device & ATOMISP_PCI_DEVICE_SOC_MASK) ==
- ATOMISP_PCI_DEVICE_SOC_CHT && ATOMISP_USE_YUVPP(asd))
+ masked_dev = isp->pdev->device & ATOMISP_PCI_DEVICE_SOC_MASK;
+
+ if (masked_dev == ATOMISP_PCI_DEVICE_SOC_CHT &&
+ ATOMISP_USE_YUVPP(asd))
isp->dfs = &dfs_config_cht_soc;
if (isp->dfs->lowest_freq == 0 || isp->dfs->max_freq_at_vmin == 0 ||
--
1.9.1
[toc] | [next] | [standalone]
| From | Alan Cox <alan@linux.intel.com> |
|---|---|
| Date | 2017-03-30 13:00 +0200 |
| Message-ID | <tqFY5-59J-11@gated-at.bofh.it> |
| In reply to | #1612585 |
On Thu, 2017-03-30 at 15:24 +0900, Daeseok Youn wrote: > The condition line in if-statement is needed to be shorthen to > improve readability. > > Signed-off-by: Daeseok Youn <daeseok.youn@gmail.com> > --- How about a define for ATOMISP_IS_CHT(isp) instead - as we will need these tests in other places where there are ISP2400/ISP2401 ifdefs ? Alan
[toc] | [prev] | [next] | [standalone]
| From | DaeSeok Youn <daeseok.youn@gmail.com> |
|---|---|
| Date | 2017-03-30 17:50 +0200 |
| Subject | Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() |
| Message-ID | <tqKuK-8ry-19@gated-at.bofh.it> |
| In reply to | #1612953 |
2017-03-30 19:52 GMT+09:00 Alan Cox <alan@linux.intel.com>: > On Thu, 2017-03-30 at 15:24 +0900, Daeseok Youn wrote: >> The condition line in if-statement is needed to be shorthen to >> improve readability. >> >> Signed-off-by: Daeseok Youn <daeseok.youn@gmail.com> >> --- > > How about a define for ATOMISP_IS_CHT(isp) instead - as we will need hmm.. I think there is another way to get a *device*(unsigned short or __u32) to mask with "ATOMISP_PCI_DEVICE_SOC_MASK". In the atomisp_freq_scaling() function, the "device" value is getting started from "isp" structure. (isp->pdev->device) if the function has only "pci_dev" struction as a parameter and it need to check the CHT. Then we cannot use the definition like ATOMISP_IS_CHT(isp). it means we have another definition to check the CHT. Am I right? > these tests in other places where there are ISP2400/ISP2401 ifdefs ? I am not sure whether these tests are needed in other place or not. (Actually, I didn't find good H/W reference for Atom ISP device - Can you please share the link to refer document like H/W manual to develop?) I have tried to clean up the code first. in the meantime, I will have a look at the document if I have good reference manual. Thanks. Regards, Daeseok. > > Alan >
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web