Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1613239

Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling()

From DaeSeok Youn <daeseok.youn@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling()
Date 2017-03-30 17:50 +0200
Message-ID <tqKuK-8ry-19@gated-at.bofh.it> (permalink)
References <tqBKN-2aA-1@gated-at.bofh.it> <tqFY5-59J-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2017-03-30 19:52 GMT+09:00 Alan Cox <alan@linux.intel.com>:
> On Thu, 2017-03-30 at 15:24 +0900, Daeseok Youn wrote:
>> The condition line in if-statement is needed to be shorthen to
>> improve readability.
>>
>> Signed-off-by: Daeseok Youn <daeseok.youn@gmail.com>
>> ---
>
> How about a define for ATOMISP_IS_CHT(isp) instead - as we will need
hmm.. I think there is another way to get a *device*(unsigned short or
__u32) to mask with "ATOMISP_PCI_DEVICE_SOC_MASK".
In the atomisp_freq_scaling() function, the "device" value is getting
started from "isp" structure.
(isp->pdev->device)

if the function has only "pci_dev" struction as a parameter and it
need to check the CHT. Then we cannot use the definition like
ATOMISP_IS_CHT(isp). it means we have another definition to check the
CHT.

Am I right?

> these tests in other places where there are ISP2400/ISP2401 ifdefs ?
I am not sure whether these tests are needed in other place or not.
(Actually, I didn't find good H/W reference for Atom ISP device - Can
you please share the link to refer document like H/W manual to
develop?) I have tried to clean up the code first. in the meantime, I
will have a look at the document if I have good reference manual.

Thanks.
Regards,
Daeseok.
>
> Alan
>

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] staging: atomisp: simplify the if condition in  atomisp_freq_scaling() Daeseok Youn <daeseok.youn@gmail.com> - 2017-03-30 08:30 +0200
  Re: [PATCH 1/2] staging: atomisp: simplify the if condition in  atomisp_freq_scaling() Alan Cox <alan@linux.intel.com> - 2017-03-30 13:00 +0200
    Re: [PATCH 1/2] staging: atomisp: simplify the if condition in atomisp_freq_scaling() DaeSeok Youn <daeseok.youn@gmail.com> - 2017-03-30 17:50 +0200

csiph-web